Skip to content

Commit

Permalink
Bumped SceneFX version to 0.2.1 (#15)
Browse files Browse the repository at this point in the history
* Bumped SceneFX version to 0.2.1

* Update .SRCINFO

* Removed unneeded PKGBUILD variables

* scenefx-git now replaces scenefx
  • Loading branch information
ErikReider authored Feb 16, 2025
1 parent d0adaf1 commit a177338
Show file tree
Hide file tree
Showing 6 changed files with 27 additions and 25 deletions.
9 changes: 5 additions & 4 deletions COPR/scenefx/scenefx.rpkg.spec
Original file line number Diff line number Diff line change
@@ -1,14 +1,15 @@
# vim: syntax=spec

%global tag 0.2
%global micro_version .1

Name: scenefx
Version: %{tag}
Version: %{tag}%{micro_version}
Release: 1%{?dist}
Summary: A drop-in replacement for the wlroots scene API that allows wayland compositors to render surfaces with eye-candy effects
License: MIT
URL: https://github.com/wlrfx/scenefx
Source0: %{url}/archive/refs/tags/%{tag}.tar.gz
Source0: %{url}/archive/refs/tags/%{tag}%{micro_version}.tar.gz


BuildRequires: gcc
Expand Down Expand Up @@ -73,9 +74,9 @@ MESON_OPTIONS=(


%files devel
%{_includedir}/scenefx
%{_includedir}/scenefx-%{tag}/scenefx
%{_libdir}/libscenefx-%{tag}.so
%{_libdir}/pkgconfig/%{name}.pc
%{_libdir}/pkgconfig/scenefx-%{tag}.pc


# Changelog will be empty until you make first annotated Git tag.
Expand Down
7 changes: 3 additions & 4 deletions aur/scenefx-0.1/PKGBUILD
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# Maintainer: Erik Reider <[email protected]>

_pkgname=scenefx
_pkgver=0.1
pkgname="$_pkgname-$_pkgver"
pkgname="scenefx-$_pkgver"
pkgver="$_pkgver"
pkgrel=1
license=("MIT")
Expand All @@ -26,12 +25,12 @@ makedepends=(
optdepends=()
provides=("libscenefx.so")
options=("debug")
source=("${_pkgname}-${_pkgver}.tar.gz::${url}/archive/refs/tags/$_pkgver.tar.gz")
source=("scenefx-${_pkgver}.tar.gz::${url}/archive/refs/tags/$_pkgver.tar.gz")
sha512sums=("SKIP")

build() {
export PKG_CONFIG_PATH='/usr/lib/wlroots0.17/pkgconfig'
arch-meson -Dwerror=false "${_pkgname}-${_pkgver}" build
arch-meson -Dwerror=false "scenefx-${_pkgver}" build
meson compile -C build
}

Expand Down
3 changes: 2 additions & 1 deletion aur/scenefx-git/.SRCINFO
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
pkgbase = scenefx-git
pkgdesc = A drop-in replacement for the wlroots scene API that allows wayland compositors to render surfaces with eye-candy effects
pkgver = r265.914b2a9
pkgver = r269.87c0e8b
pkgrel = 1
url = https://github.com/wlrfx/scenefx
arch = x86_64
Expand All @@ -16,6 +16,7 @@ pkgbase = scenefx-git
depends = libpixman-1.so
depends = libwlroots-0.18.so
provides = libscenefx-0.2.so
replaces = scenefx
options = debug
source = scenefx::git+https://github.com/wlrfx/scenefx.git
sha512sums = SKIP
Expand Down
15 changes: 8 additions & 7 deletions aur/scenefx-git/PKGBUILD
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Maintainer: Erik Reider <[email protected]>

_pkgname=scenefx
_pkgver=0.2
pkgname="$_pkgname-git"
pkgver=r265.914b2a9
_base_version=0.2

pkgname="scenefx-git"
pkgver=r269.87c0e8b
pkgrel=1
license=("MIT")
pkgdesc="A drop-in replacement for the wlroots scene API that allows wayland compositors to render surfaces with eye-candy effects"
Expand All @@ -24,19 +24,20 @@ makedepends=(
"wayland-protocols"
)
optdepends=()
provides=("libscenefx-$_pkgver.so")
provides=("libscenefx-$_base_version.so")
replaces=("scenefx")
options=("debug")
source=("${pkgname%-*}::git+${url}.git")
sha512sums=("SKIP")

pkgver() {
cd "$_pkgname"
cd "scenefx"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}

build() {
export PKG_CONFIG_PATH='/usr/lib/wlroots0.18/pkgconfig'
arch-meson -Dwerror=false "$_pkgname" build
arch-meson -Dwerror=false "scenefx" build
meson compile -C build
}

Expand Down
4 changes: 2 additions & 2 deletions aur/scenefx/.SRCINFO
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
pkgbase = scenefx
pkgdesc = A drop-in replacement for the wlroots scene API that allows wayland compositors to render surfaces with eye-candy effects
pkgver = 0.2
pkgver = 0.2.1
pkgrel = 1
url = https://github.com/wlrfx/scenefx
arch = x86_64
Expand All @@ -17,7 +17,7 @@ pkgbase = scenefx
depends = wlroots
provides = libscenefx-0.2.so
options = debug
source = scenefx-0.2.tar.gz::https://github.com/wlrfx/scenefx/archive/refs/tags/0.2.tar.gz
source = scenefx-0.2.1.tar.gz::https://github.com/wlrfx/scenefx/archive/refs/tags/0.2.1.tar.gz
sha512sums = SKIP

pkgname = scenefx
14 changes: 7 additions & 7 deletions aur/scenefx/PKGBUILD
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Maintainer: Erik Reider <[email protected]>

_pkgname=scenefx
_pkgver=0.2
pkgname="$_pkgname"
pkgver="$_pkgver"
_base_version="0.2"

pkgname=scenefx
pkgver="${_base_version}.1"
pkgrel=1
license=("MIT")
pkgdesc="A drop-in replacement for the wlroots scene API that allows wayland compositors to render surfaces with eye-candy effects"
Expand All @@ -24,13 +24,13 @@ makedepends=(
"wayland-protocols"
)
optdepends=()
provides=("libscenefx-$_pkgver.so")
provides=("libscenefx-$_base_version.so")
options=("debug")
source=("${_pkgname}-${_pkgver}.tar.gz::${url}/archive/refs/tags/$_pkgver.tar.gz")
source=("scenefx-${pkgver}.tar.gz::${url}/archive/refs/tags/$pkgver.tar.gz")
sha512sums=("SKIP")

build() {
arch-meson -Dwerror=false "${_pkgname}-${_pkgver}" build
arch-meson -Dwerror=false "scenefx-${pkgver}" build
meson compile -C build
}

Expand Down

0 comments on commit a177338

Please sign in to comment.