-
Notifications
You must be signed in to change notification settings - Fork 2
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Bumped SceneFX version to 0.2.1 (#15)
* Bumped SceneFX version to 0.2.1 * Update .SRCINFO * Removed unneeded PKGBUILD variables * scenefx-git now replaces scenefx
- Loading branch information
1 parent
d0adaf1
commit a177338
Showing
6 changed files
with
27 additions
and
25 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,7 @@ | ||
# Maintainer: Erik Reider <[email protected]> | ||
|
||
_pkgname=scenefx | ||
_pkgver=0.1 | ||
pkgname="$_pkgname-$_pkgver" | ||
pkgname="scenefx-$_pkgver" | ||
pkgver="$_pkgver" | ||
pkgrel=1 | ||
license=("MIT") | ||
|
@@ -26,12 +25,12 @@ makedepends=( | |
optdepends=() | ||
provides=("libscenefx.so") | ||
options=("debug") | ||
source=("${_pkgname}-${_pkgver}.tar.gz::${url}/archive/refs/tags/$_pkgver.tar.gz") | ||
source=("scenefx-${_pkgver}.tar.gz::${url}/archive/refs/tags/$_pkgver.tar.gz") | ||
sha512sums=("SKIP") | ||
|
||
build() { | ||
export PKG_CONFIG_PATH='/usr/lib/wlroots0.17/pkgconfig' | ||
arch-meson -Dwerror=false "${_pkgname}-${_pkgver}" build | ||
arch-meson -Dwerror=false "scenefx-${_pkgver}" build | ||
meson compile -C build | ||
} | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,9 +1,9 @@ | ||
# Maintainer: Erik Reider <[email protected]> | ||
|
||
_pkgname=scenefx | ||
_pkgver=0.2 | ||
pkgname="$_pkgname-git" | ||
pkgver=r265.914b2a9 | ||
_base_version=0.2 | ||
|
||
pkgname="scenefx-git" | ||
pkgver=r269.87c0e8b | ||
pkgrel=1 | ||
license=("MIT") | ||
pkgdesc="A drop-in replacement for the wlroots scene API that allows wayland compositors to render surfaces with eye-candy effects" | ||
|
@@ -24,19 +24,20 @@ makedepends=( | |
"wayland-protocols" | ||
) | ||
optdepends=() | ||
provides=("libscenefx-$_pkgver.so") | ||
provides=("libscenefx-$_base_version.so") | ||
replaces=("scenefx") | ||
options=("debug") | ||
source=("${pkgname%-*}::git+${url}.git") | ||
sha512sums=("SKIP") | ||
|
||
pkgver() { | ||
cd "$_pkgname" | ||
cd "scenefx" | ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" | ||
} | ||
|
||
build() { | ||
export PKG_CONFIG_PATH='/usr/lib/wlroots0.18/pkgconfig' | ||
arch-meson -Dwerror=false "$_pkgname" build | ||
arch-meson -Dwerror=false "scenefx" build | ||
meson compile -C build | ||
} | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,9 +1,9 @@ | ||
# Maintainer: Erik Reider <[email protected]> | ||
|
||
_pkgname=scenefx | ||
_pkgver=0.2 | ||
pkgname="$_pkgname" | ||
pkgver="$_pkgver" | ||
_base_version="0.2" | ||
|
||
pkgname=scenefx | ||
pkgver="${_base_version}.1" | ||
pkgrel=1 | ||
license=("MIT") | ||
pkgdesc="A drop-in replacement for the wlroots scene API that allows wayland compositors to render surfaces with eye-candy effects" | ||
|
@@ -24,13 +24,13 @@ makedepends=( | |
"wayland-protocols" | ||
) | ||
optdepends=() | ||
provides=("libscenefx-$_pkgver.so") | ||
provides=("libscenefx-$_base_version.so") | ||
options=("debug") | ||
source=("${_pkgname}-${_pkgver}.tar.gz::${url}/archive/refs/tags/$_pkgver.tar.gz") | ||
source=("scenefx-${pkgver}.tar.gz::${url}/archive/refs/tags/$pkgver.tar.gz") | ||
sha512sums=("SKIP") | ||
|
||
build() { | ||
arch-meson -Dwerror=false "${_pkgname}-${_pkgver}" build | ||
arch-meson -Dwerror=false "scenefx-${pkgver}" build | ||
meson compile -C build | ||
} | ||
|
||
|