Skip to content

Commit

Permalink
micropython-lib: update to 1.23.0 and fix compile on external mbedtls3
Browse files Browse the repository at this point in the history
* update micropython-lib to hash for 1.23.0
* remove micropython-lib unix-uffi patches

Co-authored-by: Jeffery To <[email protected]>

Signed-off-by: Glenn Strauss <[email protected]>
  • Loading branch information
gstrauss committed Oct 28, 2024
1 parent c488c16 commit b9b0145
Show file tree
Hide file tree
Showing 4 changed files with 9 additions and 96 deletions.
6 changes: 3 additions & 3 deletions lang/python/micropython-lib/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,9 +12,9 @@ PKG_RELEASE:=1

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/micropython/micropython-lib.git
PKG_SOURCE_VERSION:=d8e163bb5f3ef45e71e145c27bc4f207beaad70f
PKG_SOURCE_DATE:=20231031
PKG_MIRROR_HASH:=311651a719ae645d3e40c3c8ebf706fa2e964ac1455d84bee73606ec6d7c13a2
PKG_SOURCE_VERSION:=50ed36fbeb919753bcc26ce13a8cffd7691d06ef
PKG_SOURCE_DATE:=20240525
PKG_MIRROR_HASH:=c03c4226c461079d529b72456569797d3f87f0970e78d1c7c4d6c34d32586af4

PKG_MAINTAINER:=Jeffery To <[email protected]>
PKG_LICENSE:=MIT Python-2.0.1
Expand Down
9 changes: 6 additions & 3 deletions lang/python/micropython-lib/patches/001-build-unix-ffi.patch
Original file line number Diff line number Diff line change
Expand Up @@ -9,24 +9,27 @@
import manifestfile
import mpy_cross

@@ -310,7 +310,7 @@ def build(output_path, hash_prefix_len,
@@ -310,7 +310,10 @@ def build(output_path, hash_prefix_len,

# For now, don't process unix-ffi. In the future this can be extended to
# allow a way to request unix-ffi packages via mip.
- lib_dirs = ["micropython", "python-stdlib", "python-ecosys"]
+ lib_dirs = ["unix-ffi"] if unix_ffi else ["micropython", "python-stdlib", "python-ecosys"]
+
+ if unix_ffi:
+ manifestfile.BASE_LIBRARY_NAMES = ("unix-ffi",) + manifestfile.BASE_LIBRARY_NAMES

mpy_version, _mpy_sub_version = mpy_cross.mpy_version(mpy_cross=mpy_cross_path)
mpy_version = str(mpy_version)
@@ -438,6 +438,7 @@ def main():
@@ -438,6 +441,7 @@ def main():

cmd_parser = argparse.ArgumentParser(description="Compile micropython-lib for serving to mip.")
cmd_parser.add_argument("--output", required=True, help="output directory")
+ cmd_parser.add_argument("--unix-ffi", action="store_true", help="process unix-ffi packages")
cmd_parser.add_argument("--hash-prefix", default=8, type=int, help="hash prefix length")
cmd_parser.add_argument("--mpy-cross", default=None, help="optional path to mpy-cross binary")
cmd_parser.add_argument("--micropython", default=None, help="path to micropython repo")
@@ -447,7 +448,7 @@ def main():
@@ -447,7 +451,7 @@ def main():
sys.path.append(os.path.join(args.micropython, "tools")) # for manifestfile
sys.path.append(os.path.join(args.micropython, "mpy-cross")) # for mpy_cross

Expand Down
53 changes: 0 additions & 53 deletions lang/python/micropython-lib/patches/002-add-unix-ffi-os-path.patch

This file was deleted.

37 changes: 0 additions & 37 deletions lang/python/micropython-lib/patches/003-add-unix-ffi-uu.patch

This file was deleted.

0 comments on commit b9b0145

Please sign in to comment.