Skip to content

Commit

Permalink
streamlink: update to 6.7.4
Browse files Browse the repository at this point in the history
Also fix pkgbase to match with pkgname
  • Loading branch information
Biswa96 committed Jun 16, 2024
1 parent cfe19d1 commit c532b02
Showing 1 changed file with 13 additions and 17 deletions.
30 changes: 13 additions & 17 deletions mingw-w64-streamlink/PKGBUILD
Original file line number Diff line number Diff line change
@@ -1,35 +1,31 @@
# Contributor: Jason Qiu <[email protected]>

_realname=streamlink
pkgbase=mingw-w64-python-${_realname}
pkgbase=mingw-w64-${_realname}
pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}")
pkgver=5.5.1
pkgrel=2
pkgver=6.7.4
pkgrel=1
pkgdesc="A CLI utility that extracts streams from various services and pipes them into a video player of choice. (mingw-w64)"
arch=('any')
mingw_arch=('mingw64' 'ucrt64' 'clang64' 'clangarm64')
url="https://github.com/streamlink/streamlink"
msys2_references=(
'archlinux: streamlink'
'pypi: streamlink'
)
msys2_repository_url='https://github.com/streamlink/streamlink/'
url='https://streamlink.github.io/'
license=('spdx:BSD-2-Clause')
depends=("${MINGW_PACKAGE_PREFIX}-python"-{pycryptodome,isodate,pycountry,requests,pysocks,websocket-client,charset-normalizer})
makedepends=("${MINGW_PACKAGE_PREFIX}-python-"{build,installer,setuptools,versioningit,wheel})
checkdepends=("${MINGW_PACKAGE_PREFIX}-python-"{freezegun,pytest,pytest-asyncio,requests-mock})
depends=("${MINGW_PACKAGE_PREFIX}-python-"{certifi,isodate,lxml,pycountry,pycryptodome,pysocks,requests,trio,trio-websocket,typing_extensions,urllib3,websocket-client})
makedepends=("${MINGW_PACKAGE_PREFIX}-python-"{build,installer,setuptools,wheel})
optdepends=("${MINGW_PACKAGE_PREFIX}-ffmpeg: Required to play streams that are made up of separate audio and video streams, eg. YouTube 1080p+")
options=('!strip')
source=("${_realname}-${pkgver}.tar.gz::https://github.com/streamlink/streamlink/releases/download/${pkgver}/${_realname}-${pkgver}.tar.gz")
sha256sums=('b2b4fe8d6436dbe7bcec78de2d4bb780156388561435b61a1963156e9fc5fbd0')

prepare() {
cp -r "${_realname}-${pkgver}" "python-build-${MSYSTEM}"

# Set version for setuptools_scm
export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
}
source=("https://github.com/${_realname}/${_realname}/releases/download/${pkgver}/${_realname}-${pkgver}.tar.gz"{,.asc})
sha256sums=('9337537ab119fe77524a5d665aaecebbfb06e2cb8df28d1260d92876425751ce'
'SKIP')
validpgpkeys=('CDAC41B9122470FAF357A9D344448A298D5C3618') # Streamlink signing key <[email protected]>

build() {
cd "${srcdir}/python-build-${MSYSTEM}"
cp -r "${_realname}-${pkgver}" "python-build-${MSYSTEM}" && cd "python-build-${MSYSTEM}"
${MINGW_PREFIX}/bin/python -m build --wheel --skip-dependency-check --no-isolation
}

Expand Down

0 comments on commit c532b02

Please sign in to comment.