Skip to content

Commit

Permalink
Merge pull request #21202 from lazka/libgcrypt-1.11.0
Browse files Browse the repository at this point in the history
libgcrypt: Update to 1.11.0
  • Loading branch information
lazka authored Jun 23, 2024
2 parents 8082382 + a9a0d4c commit a409aac
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 5 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
From cc1d2f0148e9c9bc4f1c2eb771cb65f1d025ebbe Mon Sep 17 00:00:00 2001
From: Jussi Kivilinna <[email protected]>
Date: Sat, 22 Jun 2024 15:51:06 +0300
Subject: [PATCH] src/hwf-x86: disable inline assembly CFI directivies for
WIN32

* src/hwf-x86.c (CFI_ADJUST_CFA_OFFSET, CFI_PUSH4)
(CFI_POP4): Define only if _WIN32 is not defined.
--

Signed-off-by: Jussi Kivilinna <[email protected]>
---
src/hwf-x86.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/hwf-x86.c b/src/hwf-x86.c
index bda14d9d..d9d34c0e 100644
--- a/src/hwf-x86.c
+++ b/src/hwf-x86.c
@@ -39,7 +39,7 @@
#if defined (__i386__) && SIZEOF_UNSIGNED_LONG == 4 && defined (__GNUC__)
# define HAS_X86_CPUID 1

-#ifdef HAVE_GCC_ASM_CFI_DIRECTIVES
+#if defined(HAVE_GCC_ASM_CFI_DIRECTIVES) && !defined(_WIN32)
# define CFI_ADJUST_CFA_OFFSET(off) ".cfi_adjust_cfa_offset " #off "\n\t"
# define CFI_PUSH4 CFI_ADJUST_CFA_OFFSET(4)
# define CFI_POP4 CFI_ADJUST_CFA_OFFSET(-4)
--
2.43.0

15 changes: 10 additions & 5 deletions mingw-w64-libgcrypt/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,8 +4,8 @@
_realname=libgcrypt
pkgbase="mingw-w64-${_realname}"
pkgname="${MINGW_PACKAGE_PREFIX}-${_realname}"
pkgver=1.10.3
pkgrel=1
pkgver=1.11.0
pkgrel=2
pkgdesc="General purpose cryptographic library based on the code from GnuPG (mingw-w64)"
arch=('any')
mingw_arch=('mingw32' 'mingw64' 'ucrt64' 'clang64' 'clang32' 'clangarm64')
Expand All @@ -21,22 +21,27 @@ makedepends=("${MINGW_PACKAGE_PREFIX}-autotools"
options=('staticlibs' 'strip')
source=("https://gnupg.org/ftp/gcrypt/libgcrypt/${_realname}-${pkgver}.tar.bz2"{,.sig}
'libgcrypt-use-correct-def-file.patch'
'Smarter-fig2dev-detection.all.patch')
'Smarter-fig2dev-detection.all.patch'
'0001-src-hwf-x86-disable-inline-assembly-CFI-directivies-.patch')
# https://gnupg.org/signature_key.html
validpgpkeys=('5B80C5754298F0CB55D8ED6ABCEF7E294B092E28' # Andre Heinecke (Release Signing Key)
'6DAA6E64A76D2840571B4902528897B826403ADA' # Werner Koch (dist signing 2020)
'AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD' # Niibe Yutaka (GnuPG Release Key)
'02F38DFF731FF97CB039A1DA549E695E905BA208') # GnuPG.com (Release Signing Key 2021)
sha256sums=('8b0870897ac5ac67ded568dcfadf45969cfa8a6beb0fd60af2a9eadc2a3272aa'
sha256sums=('09120c9867ce7f2081d6aaa1775386b98c2f2f246135761aae47d81f58685b9c'
'SKIP'
'55cf915badebb4b3cfa671eea725aebb77be791aa39a19caef090ded4f38d8eb'
'd6855fc9b7a3a7fa440be1d9ae3477f8c08524d1aab1a8c7bb26d62b55382f72')
'd6855fc9b7a3a7fa440be1d9ae3477f8c08524d1aab1a8c7bb26d62b55382f72'
'b8fff6317fd26cb025a83d8b7ed71ee6bd32710713891bcb4347adaa1c55ec2d')

prepare() {
cd "${srcdir}/${_realname}-${pkgver}"
patch -p1 -i "${srcdir}"/libgcrypt-use-correct-def-file.patch
patch -p1 -i "${srcdir}"/Smarter-fig2dev-detection.all.patch

# https://dev.gnupg.org/T7175#187690
patch -p1 -i "${srcdir}"/0001-src-hwf-x86-disable-inline-assembly-CFI-directivies-.patch

autoreconf -fiv
}

Expand Down

0 comments on commit a409aac

Please sign in to comment.