Skip to content

Commit

Permalink
python-matplotlib-inline: update to 0.1.7
Browse files Browse the repository at this point in the history
  • Loading branch information
Biswa96 committed Jun 15, 2024
1 parent d4c6678 commit 2fd2f6c
Showing 1 changed file with 17 additions and 16 deletions.
33 changes: 17 additions & 16 deletions mingw-w64-python-matplotlib-inline/PKGBUILD
Original file line number Diff line number Diff line change
@@ -1,45 +1,46 @@
# Maintainer: Naveen M K <[email protected]>

_pyname=matplotlib-inline
_pyname=matplotlib_inline
_realname=matplotlib-inline
pkgbase=mingw-w64-python-${_realname}
pkgname=("${MINGW_PACKAGE_PREFIX}-python-${_realname}")
pkgver=0.1.6
pkgrel=2
pkgver=0.1.7
pkgrel=1
pkgdesc='Inline Matplotlib backend for Jupyter (mingw-w64)'
arch=('any')
mingw_arch=('mingw64' 'ucrt64' 'clang64' 'clangarm64')
msys2_references=(
'archlinux:python-matplotlib-inline'
'pypi: matplotlib-inline'
)
msys2_repository_url='https://github.com/ipython/matplotlib-inline'
url="https://pypi.org/project/matplotlib-inline/"
license=('spdx:BSD-3-Clause')
depends=(
"${MINGW_PACKAGE_PREFIX}-python"
"${MINGW_PACKAGE_PREFIX}-python-traitlets"
)
makedepends=(
"${MINGW_PACKAGE_PREFIX}-python-build"
"${MINGW_PACKAGE_PREFIX}-python-installer"
"${MINGW_PACKAGE_PREFIX}-python-setuptools"
"${MINGW_PACKAGE_PREFIX}-python-wheel"
)
optdepends=("${MINGW_PACKAGE_PREFIX}-python-matplotlib")
source=("https://pypi.org/packages/source/${_pyname::1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
sha256sums=('f887e5f10ba98e8d2b150ddcf4702c1e5f8b3a20005eb0f74bfdbd360ee6f304')

prepare() {
cd "$srcdir"
rm -rf python-build-${MSYSTEM} | true
cp -r "${_pyname//_/-}-$pkgver" "python-build-${MSYSTEM}"
export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
}
sha256sums=('8423b23ec666be3d16e16b60bdd8ac4e86e840ebd1dd11a30b9f117f2fa0ab90')

build() {
cd "${srcdir}/python-build-${MSYSTEM}"
${MINGW_PREFIX}/bin/python setup.py build
cp -r "${_pyname}-${pkgver}" "python-build-${MSYSTEM}" && cd "python-build-${MSYSTEM}"
${MINGW_PREFIX}/bin/python -m build --wheel --skip-dependency-check --no-isolation
}

package() {
cd "${srcdir}/python-build-${MSYSTEM}"
MSYS2_ARG_CONV_EXCL="--prefix=;--install-scripts=;--install-platlib=" \
${MINGW_PREFIX}/bin/python setup.py install --prefix=${MINGW_PREFIX} \
--root="${pkgdir}" --optimize=1 --skip-build

MSYS2_ARG_CONV_EXCL="--prefix=" \
${MINGW_PREFIX}/bin/python -m installer --prefix=${MINGW_PREFIX} \
--destdir="${pkgdir}" dist/*.whl

install -Dm644 LICENSE "${pkgdir}${MINGW_PREFIX}/share/licenses/python-${_realname}/LICENSE"
}

0 comments on commit 2fd2f6c

Please sign in to comment.