Skip to content

Commit

Permalink
13.12.0 final deb - round 0
Browse files Browse the repository at this point in the history
  • Loading branch information
Jess Portnoy committed Jan 29, 2018
1 parent f8abc31 commit 8b31ce2
Show file tree
Hide file tree
Showing 5 changed files with 500 additions and 0 deletions.
19 changes: 19 additions & 0 deletions deb/kaltura-base/debian/changelog
Original file line number Diff line number Diff line change
@@ -1,3 +1,22 @@
kaltura-base (13.12.0-2) mercury; urgency=medium

* PLAT-8513: downloadAction() - set $fileSize to null if $filePath is a directory (https://github.com/kaltura/server/pull/6697)
* Chunked Encoding: enforce provided vsync setting (https://github.com/kaltura/server/pull/6686)
* change invalid_session.id to bigint (https://github.com/kaltura/server/pull/6683)
* Support setting partner and allowed types in metadata_list_without_object_filtering_partners (https://github.com/kaltura/server/pull/6679)
* New notification dispatched to channel subscribers when an entry is approved (https://github.com/kaltura/server/pull/6677)
* PLAT-8468: add new permission to create VAST cue point without URL (https://github.com/kaltura/server/pull/6665)
* Improved Chunked Encode compliance verification (https://github.com/kaltura/server/pull/6660)
* Improved Chunked Encode compliance verification (https://github.com/kaltura/server/pull/6659)
* TR-2068: Transcript Processing breaks when ACLs are in use (https://github.com/kaltura/server/pull/6658)
* PSVAMB-1496: bpm notification - send also on metadata creation (https://github.com/kaltura/server/pull/6655)
* PLAT-8465: KalturaRequestDeserializer - if params is not an array - throw API exception (https://github.com/kaltura/server/pull/6653)
* PLAT-8469: change encryption method and support encrypt of large files (https://github.com/kaltura/server/pull/6652)
* SUP-13175: New VOD content replacement notifications (https://github.com/kaltura/server/pull/6649)
* PLAT-8470 encrypt based on media type (https://github.com/kaltura/server/pull/6645)
* SUP-13353: Assign default frame rate when no encoder information is provided
-- Jess Portnoy <jess@b0f924504114> Mon, 29 Jan 2018 10:50:38 +0000

kaltura-base (13.12.0-1) mercury; urgency=low

* Switching to 13.12.0
Expand Down
76 changes: 76 additions & 0 deletions deb/kaltura-html5lib/debian/LocalSettings.php
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
<?php
/**
* This file store all of mwEmbed local configuration ( in a default svn check out this file is empty )
*
* See includes/DefaultSettings.php for a configuration options
*/

// Old kConf path
$kConfPath = '/opt/kaltura/app/alpha/config/kConf.php';
if( ! file_exists( $kConfPath ) ) {
// New kConf path
$kConfPath = '../../../app/infra/kConf.php';
if( ! file_exists( $kConfPath ) ) {
die('Error: Unable to find kConf.php at ' . $kConfPath);
}
}
// Load kaltura configuration file
require_once( $kConfPath );

$kConf = new kConf();

// Kaltura HTML5lib Version
$wgKalturaVersion = basename(getcwd()); // Gets the version by the folder name

// The default Kaltura service url:
$wgKalturaServiceUrl = wgGetUrl('cdn_api_host');
// Default Kaltura CDN url:
$wgKalturaCDNUrl = wgGetUrl('cdn_host');
// Default Stats URL
$wgKalturaStatsServiceUrl = wgGetUrl('stats_host');

// SSL host names
if( $wgHTTPProtocol == 'https' ){
$wgKalturaServiceUrl = wgGetUrl('cdn_api_host_https');
$wgKalturaCDNUrl = wgGetUrl('cdn_host_https');
$wgKalturaStatsServiceUrl = wgGetUrl('stats_host_https');
}

// Default Asset CDN Path (used in ResouceLoader.php):
$wgCDNAssetPath = $wgKalturaCDNUrl;

// Default Kaltura Cache Path
$wgScriptCacheDirectory = $kConf->get('cache_root_path') . '/html5/' . $wgKalturaVersion;

$wgLoadScript = $wgKalturaServiceUrl . '/html5/html5lib/' . $wgKalturaVersion . '/load.php';
$wgResourceLoaderUrl = $wgLoadScript;

// Salt for proxy the user IP address to Kaltura API
if( $kConf->hasParam('remote_addr_header_salt') ) {
$wgKalturaRemoteAddressSalt = $kConf->get('remote_addr_header_salt');
}

// Disable Apple HLS if defined in kConf
if( $kConf->hasParam('use_apple_adaptive') ) {
$wgKalturaUseAppleAdaptive = $kConf->get('use_apple_adaptive');
}

// Get Kaltura Supported API Features
if( $kConf->hasParam('features') ) {
$wgKalturaApiFeatures = $kConf->get('features');
}

// Allow Iframe to connect remote service
$wgKalturaAllowIframeRemoteService = true;

// Set debug for true (testing only)
$wgEnableScriptDebug = false;

// A helper function to get full URL of host
function wgGetUrl( $hostKey = null ) {
global $wgHTTPProtocol, $wgServerPort, $kConf;
if( $hostKey && $kConf->hasParam($hostKey) ) {
return $wgHTTPProtocol . '://' . $kConf->get($hostKey) . $wgServerPort;
}
return null;
}
6 changes: 6 additions & 0 deletions deb/kaltura-html5lib/debian/changelog
Original file line number Diff line number Diff line change
@@ -1,3 +1,9 @@
kaltura-html5lib (2.65.2-1) mercury; urgency=medium

* FEC-7871 - [Player V2] [Chrome] Auto-play streams playing Auto-muted regardless the configuration

-- Jess Portnoy <jess@b0f924504114> Mon, 29 Jan 2018 11:04:28 +0000

kaltura-html5lib (2.65-1) mercury; urgency=low

* FEC-7267 - YouTube player error when ad load fails
Expand Down
Loading

0 comments on commit 8b31ce2

Please sign in to comment.