Skip to content

Commit

Permalink
bugfix and bump to v0.13.1
Browse files Browse the repository at this point in the history
  • Loading branch information
dchaddock committed Feb 15, 2023
1 parent f16033f commit 748bbca
Show file tree
Hide file tree
Showing 7 changed files with 700 additions and 618 deletions.
1 change: 1 addition & 0 deletions .pylintrc
Original file line number Diff line number Diff line change
Expand Up @@ -105,6 +105,7 @@ disable=abstract-method,
unused-import,
unused-variable,
unused-wildcard-import,
use-dict-literal,
used-before-assignment,
useless-object-inheritance, # Required for Python 2 support
useless-return,
Expand Down
1,307 changes: 694 additions & 613 deletions poetry.lock

Large diffs are not rendered by default.

2 changes: 1 addition & 1 deletion pyaurorax/__init__.py
Original file line number Diff line number Diff line change
Expand Up @@ -27,7 +27,7 @@
"""

# versioning info
__version__ = "0.13.0"
__version__ = "0.13.1"

# documentation excludes
__pdoc__ = {"cli": False}
Expand Down
2 changes: 1 addition & 1 deletion pyaurorax/cli/cli.py
Original file line number Diff line number Diff line change
Expand Up @@ -37,7 +37,7 @@ def __test_connectivity(quiet=False, return_json=False):


@click.group(invoke_without_command=True)
@click.version_option(version="0.13.0")
@click.version_option(version="0.13.1")
@click.option("--api-key", type=str, help="Specify an API key")
@click.option("--api-base-url", type=str, help="Set the AuroraX API base URL")
@click.option("--verbose", "-v", is_flag=True, help="Enable verbose output")
Expand Down
2 changes: 1 addition & 1 deletion pyaurorax/ephemeris/classes/ephemeris.py
Original file line number Diff line number Diff line change
Expand Up @@ -101,5 +101,5 @@ def __repr__(self) -> str:
# return formatted representation
return f"Ephemeris(data_source={repr(self.data_source)}, epoch={repr(self.epoch)}, " \
f"location_geo={repr(self.location_geo)}, location_gsm={repr(self.location_gsm)}, " \
f"nbtrace={repr(self.nbtrace)}, nbtrace={repr(self.nbtrace)}, " \
f"nbtrace={repr(self.nbtrace)}, sbtrace={repr(self.sbtrace)}, " \
f"metadata={attr_metadata})"
2 changes: 1 addition & 1 deletion pyproject.toml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[tool.poetry]
name = "pyaurorax"
version = "0.13.0"
version = "0.13.1"
description = "Python library for interacting with the AuroraX API"
readme = "README.md"
homepage = "https://github.com/aurorax-space/pyaurorax"
Expand Down
2 changes: 1 addition & 1 deletion tests/test_suite/test_version.py
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,4 @@


def test_version():
assert __version__ == "0.13.0"
assert __version__ == "0.13.1"

0 comments on commit 748bbca

Please sign in to comment.