-
Notifications
You must be signed in to change notification settings - Fork 7
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request #37 from nexB/update-skeleton
Update skeleton
- Loading branch information
Showing
23 changed files
with
253 additions
and
423 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,6 +2,7 @@ | |
*.py[cod] | ||
|
||
# virtualenv and other misc bits | ||
/src/*.egg-info | ||
*.egg-info | ||
/dist | ||
/build | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,54 @@ | ||
# SPDX-License-Identifier: Apache-2.0 | ||
# | ||
# Copyright (c) nexB Inc. and others. All rights reserved. | ||
# ScanCode is a trademark of nexB Inc. | ||
# SPDX-License-Identifier: Apache-2.0 | ||
# See http://www.apache.org/licenses/LICENSE-2.0 for the license text. | ||
# See https://github.com/nexB/skeleton for support or download. | ||
# See https://aboutcode.org for more information about nexB OSS projects. | ||
# | ||
|
||
# Python version can be specified with `$ PYTHON_EXE=python3.x make conf` | ||
PYTHON_EXE?=python3 | ||
VENV=venv | ||
ACTIVATE?=. ${VENV}/bin/activate; | ||
|
||
dev: | ||
@echo "-> Configure the development envt." | ||
./configure --dev | ||
|
||
isort: | ||
@echo "-> Apply isort changes to ensure proper imports ordering" | ||
${VENV}/bin/isort --sl -l 100 src tests setup.py | ||
|
||
black: | ||
@echo "-> Apply black code formatter" | ||
${VENV}/bin/black -l 100 src tests setup.py | ||
|
||
doc8: | ||
@echo "-> Run doc8 validation" | ||
@${ACTIVATE} doc8 --max-line-length 100 --ignore-path docs/_build/ --quiet docs/ | ||
|
||
valid: isort black | ||
|
||
check: | ||
@echo "-> Run pycodestyle (PEP8) validation" | ||
@${ACTIVATE} pycodestyle --max-line-length=100 --exclude=.eggs,venv,lib,thirdparty,docs,migrations,settings.py,.cache . | ||
@echo "-> Run isort imports ordering validation" | ||
@${ACTIVATE} isort --sl --check-only -l 100 setup.py src tests . | ||
@echo "-> Run black validation" | ||
@${ACTIVATE} black --check --check -l 100 src tests setup.py | ||
|
||
clean: | ||
@echo "-> Clean the Python env" | ||
./configure --clean | ||
|
||
test: | ||
@echo "-> Run the test suite" | ||
${VENV}/bin/pytest -vvs | ||
|
||
docs: | ||
rm -rf docs/_build/ | ||
@${ACTIVATE} sphinx-build docs/ docs/_build/ | ||
|
||
.PHONY: conf dev check valid black isort clean test docs |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Empty file.
Oops, something went wrong.