-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge remote-tracking branch 'origin/fido' into jethro
* origin/fido: qt5: update submodules toradex: use latest u-boot and flashing scripts kontron: update to SMARC-sAMX6i BSP release v2.0, RC2 Use code.qt.io with git protocol instead of codereview Use new repo url for utils and appcontroller qt5: update submodules qtquickcompiler: update revision qtquickcompiler: update revision Fix typo in RPi overlay config Update meta layers Conflicts: conf/distro/include/colibri-imx6.conf conf/distro/include/raspberrypi2.conf conf/distro/include/toradex.inc meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-Update-default-args-for-apalis-imx6.patch meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-imx6-enable-sdboot-by-default.patch meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend meta-toradex-extras/recipes/u-boot/u-boot-toradex_git.bbappend recipes-qt/b2qt-addons/b2qt-appcontroller.bb recipes-qt/b2qt-addons/b2qt-utils.bb recipes-qt/qt5/nativesdk-qtbase_git.bbappend recipes-qt/qt5/qtbase-native_git.bbappend recipes-qt/qt5/qtbase_git.bbappend recipes-qt/qt5/qtcanvas3d_git.bbappend recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtconnectivity_git.bbappend recipes-qt/qt5/qtdeclarative-render2d_git.bb recipes-qt/qt5/qtdeclarative_git.bbappend recipes-qt/qt5/qtlocation_git.bbappend recipes-qt/qt5/qtmultimedia_git.bbappend recipes-qt/qt5/qtquickcompiler_git.bb recipes-qt/qt5/qtquickcontrols_git.bbappend recipes-qt/qt5/qtsensors_git.bbappend recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtserialport_git.bbappend recipes-qt/qt5/qttools_git.bbappend recipes-qt/qt5/qttranslations_git.bbappend recipes-qt/qt5/qtvirtualkeyboard_git.bbappend recipes-qt/qt5/qtwayland-native_git.bbappend recipes-qt/qt5/qtwayland_git.bbappend recipes-qt/qt5/qtwebengine_git.bbappend scripts/manifest.xml Change-Id: I621a82a6deeeb2b74c8179c2f46b4fa42968b636
- Loading branch information
Showing
34 changed files
with
639 additions
and
206 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
60 changes: 60 additions & 0 deletions
60
...dex-extras/recipes/u-boot/u-boot-script-toradex/apalis-imx6/0001-Update-only-u-boot.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
From 262b1dcc5f886ceb1944c8db3c1072c98d45a56e Mon Sep 17 00:00:00 2001 | ||
From: Samuli Piippo <[email protected]> | ||
Date: Wed, 14 Sep 2016 10:11:32 +0300 | ||
Subject: [PATCH] Update only u-boot | ||
|
||
--- | ||
flash_blk.scr | 8 ++++---- | ||
flash_eth.scr | 8 ++++---- | ||
2 files changed, 8 insertions(+), 8 deletions(-) | ||
|
||
diff --git a/flash_blk.scr b/flash_blk.scr | ||
index 800383c..398c4de 100644 | ||
--- a/flash_blk.scr | ||
+++ b/flash_blk.scr | ||
@@ -30,16 +30,16 @@ setenv update_2 'load ${interface} ${drive}:1 ${loadaddr} ${board_name}/boot.vfa | ||
#do it in chunks of 64M to fit into DDR RAM of the smallest module | ||
setenv update_3 'setenv filesize 4000000; setenv filepos 0; setenv blkstart a000; while test ${filesize} -eq "4000000"; do run cp_file_chunk; run set_nextpos; done; true' | ||
|
||
-setenv echo_migrate echo "successfully updated U-Boot, power-cycle and enter \"run setupdate\; run migrate\" to complete update" | ||
-setenv echo_migrate-it echo "successfully updated U-Boot, power-cycle and enter \"run setupdate\; run migrate_it\" to complete update" | ||
+setenv echo_migrate echo "successfully updated U-Boot" | ||
+setenv echo_migrate-it echo "successfully updated U-Boot" | ||
setenv migrate 'run migrate_configblock; run update_latest; reset' | ||
setenv migrate_it 'setenv module_type -it; run migrate' | ||
setenv update_v2.4b1 'run check_configblock || run migrate_configblock; run migrate_uboot_old && run echo_migrate${module_type}' | ||
setenv update_v2.5b3 'run check_configblock || run migrate_configblock; run migrate_uboot && run echo_migrate${module_type}' | ||
|
||
setenv update_latest 'run update_uboot; run update_1; run update_2; run update_kernel; run update_fdt; run update_3' | ||
-setenv update_new 'updt_fuse -n && run update_latest && reset; run update_v2.5b3' | ||
+setenv update_new 'updt_fuse -n && run update_uboot && reset; run update_v2.5b3' | ||
setenv update 'mmc bootbus 0 2 0 1 && run update_new && exit; run update_v2.4b1' | ||
setenv update_it 'setenv module_type -it; run update' | ||
|
||
-echo 'enter "run update" or "run update_it" to update the entire module' | ||
+echo 'enter "run update" or "run update_it" to update the uboot' | ||
diff --git a/flash_eth.scr b/flash_eth.scr | ||
index 804c924..2f64288 100644 | ||
--- a/flash_eth.scr | ||
+++ b/flash_eth.scr | ||
@@ -31,16 +31,16 @@ setenv update_2 'tftpboot ${loadaddr} ${board_name}/boot.vfat && run set_blkcnt | ||
#split -a 2 -b `expr 64 \* 1024 \* 1024` --numeric-suffixes=10 root.ext3 root.ext3- | ||
setenv update_3 'setenv filesize 4000000; setenv filenum 10; setenv blkstart a000; while test ${filesize} -eq "4000000"; do run cp_file_chunk; run set_nextnum; done; true' | ||
|
||
-setenv echo_migrate echo "successfully updated U-Boot, power-cycle and enter \"run setupdate\; run migrate\" to complete update" | ||
-setenv echo_migrate-it echo "successfully updated U-Boot, power-cycle and enter \"run setupdate\; run migrate_it\" to complete update" | ||
+setenv echo_migrate echo "successfully updated U-Boot" | ||
+setenv echo_migrate-it echo "successfully updated U-Boot" | ||
setenv migrate 'run migrate_configblock; run update_latest; reset' | ||
setenv migrate_it 'setenv module_type -it; run migrate' | ||
setenv update_v2.4b1 'run check_configblock || run migrate_configblock; run migrate_uboot_old && run echo_migrate${module_type}' | ||
setenv update_v2.5b3 'run check_configblock || run migrate_configblock; run migrate_uboot && run echo_migrate${module_type}' | ||
|
||
setenv update_latest 'run update_uboot; run update_1; run update_2; run update_kernel; run update_fdt; run update_3' | ||
-setenv update_new 'updt_fuse -n && run update_latest && reset; run update_v2.5b3' | ||
+setenv update_new 'updt_fuse -n && run update_uboot && reset; run update_v2.5b3' | ||
setenv update 'mmc bootbus 0 2 0 1 && run update_new && exit; run update_v2.4b1' | ||
setenv update_it 'setenv module_type -it; run update' | ||
|
||
-echo 'enter "run update" or "run update_it" to update the entire module' | ||
+echo 'enter "run update" or "run update_it" to update the uboot' |
45 changes: 45 additions & 0 deletions
45
meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/apalis-imx6/flash_blk.scr
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
test -n ${interface} || setenv interface mmc | ||
test -n ${drive} || setenv drive 1 | ||
|
||
setenv set_blkcnt 'setexpr blkcnt ${filesize} + 0x1ff && setexpr blkcnt ${blkcnt} / 0x200' | ||
setenv set_nextpos 'setexpr filepos ${filepos} + ${filesize}; setexpr blkstart ${blkstart} + ${blkcnt}' | ||
|
||
setenv check_1 'setenv conf_blk_offset 0x1fff; mmc read ${loadaddr} ${conf_blk_offset} 1' | ||
setenv check_2 'setenv conf_blk_offset 0xfff; mmc read ${loadaddr} ${conf_blk_offset} 1' | ||
setenv check_3 'setenv conf_blk_offset 0x7ff; mmc read ${loadaddr} ${conf_blk_offset} 1' | ||
setenv check_configblock 'setexpr toradex_oui_addr ${loadaddr} + 8; mw.l ${kernel_addr_r} 0x002d1400; mmc dev 0 1; run check_1 || run check_2 || run check_3; cmp.b ${kernel_addr_r} ${toradex_oui_addr} 3' | ||
|
||
setenv migrate_configblock 'run check_configblock; mmc dev 0 0 && mmc read ${loadaddr} 0x500 1 && cmp.b ${kernel_addr_r} ${toradex_oui_addr} 3 && mmc dev 0 1 && mmc write ${loadaddr} ${conf_blk_offset} 1' | ||
|
||
setenv migrate_uboot_old 'load ${interface} ${drive}:1 ${loadaddr} ${board_name}/u-boot.imx${module_type} && run set_blkcnt && mmc dev 0 0 && mmc write ${loadaddr} 2 ${blkcnt}' | ||
setenv migrate_uboot 'load ${interface} ${drive}:1 ${loadaddr} ${board_name}/u-boot.imx${module_type} && run set_blkcnt && mmc dev 0 1 && mmc write ${loadaddr} 2 ${blkcnt} && mmc bootbus 0 2 1 2 && mmc partconf 0 1 1 0' | ||
|
||
setenv cp_file_chunk 'load ${interface} ${drive}:1 ${loadaddr} ${board_name}/root.ext3 ${filesize} ${filepos}; run set_blkcnt; mmc dev 0 0 && mmc write ${loadaddr} ${blkstart} ${blkcnt}' | ||
|
||
setenv update_uboot 'load ${interface} ${drive}:1 ${loadaddr} ${board_name}/u-boot.imx${module_type} && run set_blkcnt && mmc dev 0 1 && mmc write ${loadaddr} 2 ${blkcnt} && updt_fuse && mmc bootbus 0 2 0 1 && mmc partconf 0 1 1 0 && mmc rst-function 0 1' | ||
setenv update_uboot_it 'setenv module_type -it; run update_uboot' | ||
|
||
setenv update_kernel 'load ${interface} ${drive}:1 ${loadaddr} ${board_name}/uImage && fatwrite mmc 0:1 ${loadaddr} uImage ${filesize}' | ||
|
||
setenv update_fdt 'load ${interface} ${drive}:1 ${loadaddr} ${board_name}/${fdt_file} && fatwrite mmc 0:1 ${loadaddr} ${fdt_file} ${filesize}' | ||
|
||
setenv update_configblock 'run check_configblock; load ${interface} ${drive}:1 ${loadaddr} ${board_name}/configblock.bin && mmc dev 0 1 && mmc write ${loadaddr} ${conf_blk_offset} 1' | ||
|
||
setenv update_1 'load ${interface} ${drive}:1 ${loadaddr} ${board_name}/mbr.bin && mmc dev 0 0 && mmc write ${loadaddr} 0x0 0x1' | ||
setenv update_2 'load ${interface} ${drive}:1 ${loadaddr} ${board_name}/boot.vfat && run set_blkcnt && mmc dev 0 0 && mmc write ${loadaddr} 0x2000 ${blkcnt}' | ||
#do it in chunks of 64M to fit into DDR RAM of the smallest module | ||
setenv update_3 'setenv filesize 4000000; setenv filepos 0; setenv blkstart a000; while test ${filesize} -eq "4000000"; do run cp_file_chunk; run set_nextpos; done; true' | ||
|
||
setenv echo_migrate echo "successfully updated U-Boot, power-cycle and enter \"run setupdate\; run migrate\" to complete update" | ||
setenv echo_migrate-it echo "successfully updated U-Boot, power-cycle and enter \"run setupdate\; run migrate_it\" to complete update" | ||
setenv migrate 'run migrate_configblock; run update_latest; reset' | ||
setenv migrate_it 'setenv module_type -it; run migrate' | ||
setenv update_v2.4b1 'run check_configblock || run migrate_configblock; run migrate_uboot_old && run echo_migrate${module_type}' | ||
setenv update_v2.5b3 'run check_configblock || run migrate_configblock; run migrate_uboot && run echo_migrate${module_type}' | ||
|
||
setenv update_latest 'run update_uboot; run update_1; run update_2; run update_kernel; run update_fdt; run update_3' | ||
setenv update_new 'updt_fuse -n && run update_latest && reset; run update_v2.5b3' | ||
setenv update 'mmc bootbus 0 2 0 1 && run update_new && exit; run update_v2.4b1' | ||
setenv update_it 'setenv module_type -it; run update' | ||
|
||
echo 'enter "run update" or "run update_it" to update the entire module' |
46 changes: 46 additions & 0 deletions
46
meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/apalis-imx6/flash_eth.scr
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
setenv set_blkcnt 'setexpr blkcnt ${filesize} + 0x1ff && setexpr blkcnt ${blkcnt} / 0x200' | ||
#workaround U-Boot counting in hex and split did in decimal | ||
setenv incr_decimal 'setexpr filenum ${filenum} + 1; setexpr filenrlow ${filenum} % 0x10; test ${filenrlow} -eq "a" && setexpr filenum ${filenum} + 0x6; true' | ||
setenv set_nextnum 'run incr_decimal; setexpr blkstart ${blkstart} + ${blkcnt}' | ||
|
||
setenv check_1 'setenv conf_blk_offset 0x1fff; mmc read ${loadaddr} ${conf_blk_offset} 1' | ||
setenv check_2 'setenv conf_blk_offset 0xfff; mmc read ${loadaddr} ${conf_blk_offset} 1' | ||
setenv check_3 'setenv conf_blk_offset 0x7ff; mmc read ${loadaddr} ${conf_blk_offset} 1' | ||
setenv check_configblock 'setexpr toradex_oui_addr ${loadaddr} + 8; mw.l ${kernel_addr_r} 0x002d1400; mmc dev 0 1; run check_1 || run check_2 || run check_3; cmp.b ${kernel_addr_r} ${toradex_oui_addr} 3' | ||
|
||
setenv migrate_configblock 'run check_configblock; mmc dev 0 0 && mmc read ${loadaddr} 0x500 1 && cmp.b ${kernel_addr_r} ${toradex_oui_addr} 3 && mmc dev 0 1 && mmc write ${loadaddr} ${conf_blk_offset} 1' | ||
|
||
setenv migrate_uboot_old 'tftpboot ${loadaddr} ${board_name}/u-boot.imx${module_type} && run set_blkcnt && mmc dev 0 0 && mmc write ${loadaddr} 2 ${blkcnt}' | ||
setenv migrate_uboot 'tftpboot ${loadaddr} ${board_name}/u-boot.imx${module_type} && run set_blkcnt && mmc dev 0 1 && mmc write ${loadaddr} 2 ${blkcnt} && mmc bootbus 0 2 1 2 && mmc partconf 0 1 1 0' | ||
|
||
setenv cp_file_chunk 'tftpboot ${loadaddr} ${board_name}/root.ext3-${filenum}; run set_blkcnt; mmc dev 0 0 && mmc write ${loadaddr} ${blkstart} ${blkcnt}' | ||
|
||
setenv update_uboot 'tftpboot ${loadaddr} ${board_name}/u-boot.imx${module_type} && run set_blkcnt && mmc dev 0 1 && mmc write ${loadaddr} 2 ${blkcnt} && updt_fuse && mmc bootbus 0 2 0 1 && mmc partconf 0 1 1 0 && mmc rst-function 0 1' | ||
setenv update_uboot_it 'setenv module_type -it; run update_uboot' | ||
|
||
setenv update_kernel 'tftpboot ${loadaddr} ${board_name}/uImage && fatwrite mmc 0:1 ${loadaddr} uImage ${filesize}' | ||
|
||
setenv update_fdt 'tftpboot ${loadaddr} ${board_name}/${fdt_file} && fatwrite mmc 0:1 ${loadaddr} ${fdt_file} ${filesize}' | ||
|
||
setenv update_configblock 'run check_configblock; tftpboot ${loadaddr} ${board_name}/configblock.bin && mmc dev 0 1 && mmc write ${loadaddr} ${conf_blk_offset} 1' | ||
|
||
setenv update_1 'tftpboot ${loadaddr} ${board_name}/mbr.bin && mmc dev 0 0 && mmc write ${loadaddr} 0x0 0x1' | ||
setenv update_2 'tftpboot ${loadaddr} ${board_name}/boot.vfat && run set_blkcnt && mmc dev 0 0 && mmc write ${loadaddr} 0x2000 ${blkcnt}' | ||
#do it in chunks of 64M to fit into DDR RAM of the smallest module | ||
#split root.ext3 into multiple 64M chunks before copying to TFTP folder as follows | ||
#split -a 2 -b `expr 64 \* 1024 \* 1024` --numeric-suffixes=10 root.ext3 root.ext3- | ||
setenv update_3 'setenv filesize 4000000; setenv filenum 10; setenv blkstart a000; while test ${filesize} -eq "4000000"; do run cp_file_chunk; run set_nextnum; done; true' | ||
|
||
setenv echo_migrate echo "successfully updated U-Boot, power-cycle and enter \"run setupdate\; run migrate\" to complete update" | ||
setenv echo_migrate-it echo "successfully updated U-Boot, power-cycle and enter \"run setupdate\; run migrate_it\" to complete update" | ||
setenv migrate 'run migrate_configblock; run update_latest; reset' | ||
setenv migrate_it 'setenv module_type -it; run migrate' | ||
setenv update_v2.4b1 'run check_configblock || run migrate_configblock; run migrate_uboot_old && run echo_migrate${module_type}' | ||
setenv update_v2.5b3 'run check_configblock || run migrate_configblock; run migrate_uboot && run echo_migrate${module_type}' | ||
|
||
setenv update_latest 'run update_uboot; run update_1; run update_2; run update_kernel; run update_fdt; run update_3' | ||
setenv update_new 'updt_fuse -n && run update_latest && reset; run update_v2.5b3' | ||
setenv update 'mmc bootbus 0 2 0 1 && run update_new && exit; run update_v2.4b1' | ||
setenv update_it 'setenv module_type -it; run update' | ||
|
||
echo 'enter "run update" or "run update_it" to update the entire module' |
Oops, something went wrong.