-
Notifications
You must be signed in to change notification settings - Fork 7
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
package/mosquitto: add mosquitto (#227)
Closes EXEC-159
- Loading branch information
Showing
9 changed files
with
94 additions
and
6 deletions.
There are no files selected for viewing
3 changes: 3 additions & 0 deletions
3
board/opentrons/ot2/rootfs-overlay/etc/mosquitto/mosquitto.conf
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
allow_anonymous true | ||
listener 1883 | ||
protocol mqtt |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
22 changes: 22 additions & 0 deletions
22
package/mosquitto/0001-Add-dynamic-symbols-linking-with-cmake.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
Upstream-Status: Submitted [https://github.com/eclipse/mosquitto/pull/1571] | ||
From 3fe5468f1bdca1bff1d18cf43c9e338f41aa9e32 Mon Sep 17 00:00:00 2001 | ||
From: Gianfranco Costamagna <[email protected]> | ||
Date: Wed, 22 Jan 2020 12:39:49 +0100 | ||
Subject: [PATCH] Add dynamic symbols linking with cmake too | ||
|
||
Signed-off-by: Gianfranco Costamagna <[email protected]> | ||
--- | ||
lib/CMakeLists.txt | 2 ++ | ||
1 file changed, 2 insertions(+) | ||
|
||
--- a/lib/CMakeLists.txt | ||
+++ b/lib/CMakeLists.txt | ||
@@ -94,6 +94,8 @@ | ||
OUTPUT_NAME mosquitto | ||
VERSION ${VERSION} | ||
SOVERSION 1 | ||
+ LINK_DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/linker.version | ||
+ LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/linker.version" | ||
) | ||
|
||
install(TARGETS libmosquitto |
24 changes: 24 additions & 0 deletions
24
package/mosquitto/0002-Link-correctly-with-shared-websockets-libray.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
From: Joachim Zobel <[email protected]> | ||
Date: Wed, 13 Sep 2023 09:55:34 +0200 | ||
Subject: [PATCH] Link correctly with shared websockets library if needed see: | ||
https://github.com/eclipse/mosquitto/pull/2751 | ||
|
||
Patch contributed by Joachim Zobel <[email protected]> and Daniel Engberg <[email protected]> | ||
--- | ||
Upstream-Status: Pending | ||
|
||
src/CMakeLists.txt | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt | ||
index 9380a04..dce8313 100644 | ||
--- a/src/CMakeLists.txt | ||
+++ b/src/CMakeLists.txt | ||
@@ -200,7 +200,7 @@ if (WITH_WEBSOCKETS) | ||
link_directories(${mosquitto_SOURCE_DIR}) | ||
endif (WIN32) | ||
else (STATIC_WEBSOCKETS) | ||
- set (MOSQ_LIBS ${MOSQ_LIBS} websockets) | ||
+ set (MOSQ_LIBS ${MOSQ_LIBS} websockets_shared) | ||
endif (STATIC_WEBSOCKETS) | ||
endif (WITH_WEBSOCKETS) |
27 changes: 27 additions & 0 deletions
27
package/mosquitto/0003-Mosquitto-waits-for-network-online-when-starting.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,27 @@ | ||
From: Joachim Zobel <[email protected]> | ||
Date: Wed, 13 Sep 2023 10:05:43 +0200 | ||
Subject: [PATCH] Mosquitto now waits for network-online when starting | ||
(Closes: #1036450) | ||
|
||
See: https://github.com/eclipse/mosquitto/issues/2878 | ||
--- | ||
Upstream-Status: Pending | ||
|
||
service/systemd/mosquitto.service.simple | 4 ++-- | ||
1 file changed, 2 insertions(+), 2 deletions(-) | ||
|
||
diff --git a/service/systemd/mosquitto.service.simple b/service/systemd/mosquitto.service.simple | ||
index 15ee0d6..c2a330b 100644 | ||
--- a/service/systemd/mosquitto.service.simple | ||
+++ b/service/systemd/mosquitto.service.simple | ||
@@ -1,8 +1,8 @@ | ||
[Unit] | ||
Description=Mosquitto MQTT Broker | ||
Documentation=man:mosquitto.conf(5) man:mosquitto(8) | ||
-After=network.target | ||
-Wants=network.target | ||
+After=network-online.target | ||
+Wants=network-online.target | ||
|
||
[Service] | ||
ExecStart=/usr/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,8 @@ | ||
# Locally calculated after checking gpg signature | ||
# from https://mosquitto.org/files/source/mosquitto-2.0.17.tar.gz.asc | ||
sha256 3be7a911236567c1a9fbe25baf3e3167004ba4a0c151a448ef1f7fc077dba52f mosquitto-2.0.17.tar.gz | ||
# from https://mosquitto.org/files/source/mosquitto-2.0.18.tar.gz.asc | ||
sha256 d665fe7d0032881b1371a47f34169ee4edab67903b2cd2b4c083822823f4448a mosquitto-2.0.18.tar.gz | ||
|
||
# License files | ||
sha256 d3c4ccace4e5d3cc89d34cf2a0bc85b8596bfc0a32b815d0d77f9b7c41b5350c LICENSE.txt | ||
sha256 8c349f80764d0648e645f41ef23772a70c995a0924b5235f735f4a3d09df127c epl-v20 | ||
sha256 86fc4a3f97cb769c04e8da557036c1066eb8bb22b2d0a5dd31464990fe84047c edl-v10 | ||
sha256 86fc4a3f97cb769c04e8da557036c1066eb8bb22b2d0a5dd31464990fe84047c edl-v10 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
[Unit] | ||
Description=Mosquitto MQTT broker | ||
|
||
[Service] | ||
ExecStart=/usr/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf | ||
ExecReload=/bin/kill -HUP $MAINPID | ||
Restart=always | ||
|
||
[Install] | ||
WantedBy=multi-user.target |