Skip to content

Commit

Permalink
package/python-pandas: downgrade to 1.0.5 (#222)
Browse files Browse the repository at this point in the history
We have to pick a very specific pandas version to work properly on the new buildroot (much like we did with the old buildroot):

- The version before the upgrade, 0.5.3, doesn't work with python 3.10's limited C interface (it uses an old enough cython that generated C does ++Py_REFCNT(obj) but >=3.10 doesn't have that macro resolving to an lvalue)
- The absolute latest versions require a higher version of numpy than we provide
- More recent versions than specifically the 1.0 series have something messed up in their cross-compilation and disagree with the numpy c library on the size of integers

The 1.0 series seems to work and 1.0.5 is the latest 1.0 so here we are.

Closes RQA-2413
  • Loading branch information
sfoster1 authored Mar 1, 2024
1 parent 9453106 commit 2edda12
Show file tree
Hide file tree
Showing 3 changed files with 8 additions and 18 deletions.
12 changes: 0 additions & 12 deletions package/python-pandas/0001-remove-optional-dep.patch

This file was deleted.

4 changes: 2 additions & 2 deletions package/python-pandas/python-pandas.hash
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
# md5, sha256 from https://pypi.org/pypi/pandas/json
md5 922757466055068bddebd57bf443f2ed pandas-2.1.1.tar.gz
sha256 fecb198dc389429be557cde50a2d46da8434a17fe37d7d41ff102e3987fd947b pandas-2.1.1.tar.gz
md5 5183db713194e6fbc96c45f30a0d1311 pandas-1.0.5.tar.gz
sha256 69c5d920a0b2a9838e677f78f4dde506b95ea8e4d30da25859db6469ded84fa8 pandas-1.0.5.tar.gz
# Locally computed sha256 checksums
sha256 79e4e818a662c6c02b052499bd6ededa18e780d3c026339834cc09455fea6ced LICENSE
10 changes: 6 additions & 4 deletions package/python-pandas/python-pandas.mk
Original file line number Diff line number Diff line change
Expand Up @@ -4,10 +4,10 @@
#
################################################################################

PYTHON_PANDAS_VERSION = 2.1.1
PYTHON_PANDAS_VERSION = 1.0.5
PYTHON_PANDAS_SOURCE = pandas-$(PYTHON_PANDAS_VERSION).tar.gz
PYTHON_PANDAS_SITE = https://files.pythonhosted.org/packages/3d/0e/2c225d7a5de6ca0ec7d729aff6ef560544596f3a9bfed77f6dbc1713dbb5
PYTHON_PANDAS_DEPENDENCIES = host-python-numpy host-python-cython host-python-versioneer
PYTHON_PANDAS_SITE = https://files.pythonhosted.org/packages/31/29/ede692aa6547dfc1f07a4d69e8411b35225218bcfbe9787e78b67a35d103
PYTHON_PANDAS_DEPENDENCIES = python-numpy host-python-numpy host-python-cython host-python-versioneer host-python-numpy
PYTHON_PANDAS_SETUP_TYPE = setuptools
PYTHON_PANDAS_LICENSE = BSD
PYTHON_PANDAS_LICENSE_FILES = LICENSE
Expand All @@ -19,4 +19,6 @@ endef
PYTHON_PANDAS_POST_INSTALL_TARGET_HOOKS += PYTHON_PANDAS_REMOVE_TESTS
endif

$(eval $(meson-package))
PYTHON_PANDAS_ENV=SETUPTOOLS_BUILD_ARGS="--plat-name=linux-armv7l"

$(eval $(python-package))

0 comments on commit 2edda12

Please sign in to comment.