Skip to content

Commit

Permalink
Merge pull request #34 from nikhil-zinjurde-imgtec/master
Browse files Browse the repository at this point in the history
Merge dev to master
  • Loading branch information
nikhil-zinjurde-imgtec authored Jul 20, 2016
2 parents 2a29b29 + dd99a41 commit a07d718
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,7 @@ Package | Description
:---------------- | -----------------------------
button-gateway | Button gateway is an application running on Ci40 which acts as a gateway for MikroE boards.
button-led-controller | Button-Led controller is an application for controlling LED on Ci40 as per button-press on Clicker boards.
motion-led-controller | Motion-Led controller is an application running on Ci40 which controls the LED based on the motion sensor events from MikroE board.
device-manager | Device manager is an application for provisioning devices with access details for FlowCloud.
libflow | Binary package for FlowLibraries.
webscripts | Webscripts to provision Gateway and Constrained devices.
Expand Down
51 changes: 51 additions & 0 deletions motion-led-controller/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=motion-led-controller
PKG_VERSION:=0.9.3
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/CreatorKit/motion-led-controller.git

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_VERSION:=$(PKG_VERSION)
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)

CMAKE_INSTALL:=1

CMAKE_OPTIONS += -DSTAGING_DIR=$(STAGING_DIR)

include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk

define Package/motion-led-controller
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:= +awalwm2m
TITLE:=Motion Led Controller app
endef

define Package/motion-led-controller/description
Imagination Technologies motion-led controller app
endef

define Build/Compile
$(call Build/Compile/Default,all)
endef

define Build/Clean
$(call Build/Compile/Default,clean)
endef

define Package/motion-led-controller/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/set_led.sh $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/motion_led_controller_continuous.sh $(1)/usr/bin
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/motion_led_controller_appd $(1)/etc/init.d/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/motion_led_controller_continuousd $(1)/etc/init.d/
endef

$(eval $(call BuildPackage,$(PKG_NAME)))

0 comments on commit a07d718

Please sign in to comment.