Skip to content

Commit

Permalink
Merge pull request #29 from abhijit-mahajani-imgtec/master
Browse files Browse the repository at this point in the history
Merge dev to master
  • Loading branch information
nikhil-zinjurde-imgtec authored Jul 6, 2016
2 parents 64da6b5 + 1739eca commit 8683638
Show file tree
Hide file tree
Showing 2 changed files with 11 additions and 12 deletions.
3 changes: 1 addition & 2 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -5,10 +5,9 @@ Feeds for CreatorKit packages.
Package | Description
:---------------- | -----------------------------
button-gateway | Button gateway is an application running on Ci40 which acts as a gateway for MikroE boards.
button-led-controller | Button-Led controller is an application for controlling LED on Ci40 as per button-press on Clicker boards.
device-manager | Device manager is an application for provisioning devices with access details for FlowCloud.
led-controller | Led controller is an application for controlling LED on Ci40 as per button-press on Clicker boards.
libflow | Binary package for FlowLibraries.
libflow-ex | Examples for using FlowLibraries.
webscripts | Webscripts to provision Gateway and Constrained devices.

Command | Description
Expand Down
20 changes: 10 additions & 10 deletions led-controller/Makefile → button-led-controller/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=led-controller
PKG_NAME:=button-led-controller
PKG_VERSION:=0.9.1
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=$(TOPDIR)/../../packages/led-controller
PKG_SOURCE_URL:=$(TOPDIR)/../../packages/button-led-controller

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_VERSION:=$(PKG_VERSION)
Expand All @@ -19,15 +19,15 @@ CMAKE_OPTIONS += -DSTAGING_DIR=$(STAGING_DIR)
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk

define Package/led-controller
define Package/button-led-controller
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:= +awalwm2m
TITLE:=Led Controller app
TITLE:=Button-Led Controller app
endef

define Package/led-controller/description
Imagination Technologies led controller app
define Package/button-led-controller/description
Imagination Technologies button-led controller app
endef

define Build/Compile
Expand All @@ -38,14 +38,14 @@ define Build/Clean
$(call Build/Compile/Default,clean)
endef

define Package/led-controller/install
define Package/button-led-controller/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/set_led.sh $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/led_controller_continuous.sh $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/button_led_controller_continuous.sh $(1)/usr/bin
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/led_controller_appd $(1)/etc/init.d/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/led_controller_continuousd $(1)/etc/init.d/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/button_led_controller_appd $(1)/etc/init.d/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/button_led_controller_continuousd $(1)/etc/init.d/
endef

$(eval $(call BuildPackage,$(PKG_NAME)))

0 comments on commit 8683638

Please sign in to comment.