Skip to content

Commit

Permalink
chore(master): Release 0.72.0 (#11315)
Browse files Browse the repository at this point in the history
🤖 I have created a release *beep* *boop*
---


<details><summary>aztec-package: 0.72.0</summary>

##
[0.72.0](aztec-package-v0.71.0...aztec-package-v0.72.0)
(2025-01-24)


### Features

* Gaztec
([#11229](#11229))
([79f810d](79f810d))
* Lazy wasm pt. 2
([#11410](#11410))
([01510f4](01510f4))
* Lazy wasm pt3
([#11435](#11435))
([7068d05](7068d05))


### Bug Fixes

* Init fee juice contract in sandbox
([#11379](#11379))
([caab526](caab526))
* Use simulation to estimate gas used
([#11211](#11211))
([63776f0](63776f0))


### Miscellaneous

* Trace propagation from json rpc client to server
([#11325](#11325))
([85ccc15](85ccc15))
</details>

<details><summary>barretenberg.js: 0.72.0</summary>

##
[0.72.0](barretenberg.js-v0.71.0...barretenberg.js-v0.72.0)
(2025-01-24)


### Features

* Gaztec
([#11229](#11229))
([79f810d](79f810d))
* Lazy wasm pt.1
([#11371](#11371))
([864bc6f](864bc6f))
* Lazy wasm pt3
([#11435](#11435))
([7068d05](7068d05))
* UH recursion in the browser
([#11049](#11049))
([c3c04a4](c3c04a4))


### Bug Fixes

* Lint
([#11389](#11389))
([87b0dee](87b0dee))
</details>

<details><summary>aztec-packages: 0.72.0</summary>

##
[0.72.0](aztec-packages-v0.71.0...aztec-packages-v0.72.0)
(2025-01-24)


### ⚠ BREAKING CHANGES

* **aztec.js:** remove field from aztec address like
([#11350](#11350))
* public logs
([#11091](#11091))

### Features

* **avm:** Address and class id derivation setup
([#11354](#11354))
([5f3cffc](5f3cffc))
* **avm:** Bytecode manager changes
([#11347](#11347))
([4a9c072](4a9c072))
* **avm:** Include initial tree roots in DB
([#11360](#11360))
([4d149be](4d149be))
* **avm:** Interactive debugger
([#11477](#11477))
([53e57d3](53e57d3))
* Consensus layer in spartan
([#11105](#11105))
([55dd03c](55dd03c))
* Eccvm sumcheck with commitments to round univariates
([#11206](#11206))
([fe34b05](fe34b05))
* Gaztec
([#11229](#11229))
([79f810d](79f810d))
* Lazy wasm pt. 2
([#11410](#11410))
([01510f4](01510f4))
* Lazy wasm pt.1
([#11371](#11371))
([864bc6f](864bc6f))
* Lazy wasm pt3
([#11435](#11435))
([7068d05](7068d05))
* **p2p:** Batch request response
([#11331](#11331))
([13b379d](13b379d))
* **p2p:** Request response node sampling
([#11330](#11330))
([6426d90](6426d90))
* **p2p:** Send goodbye messages on disconnecting to peers
([#10920](#10920))
([046968f](046968f))
* **p2p:** Validator use batch requests
([#11332](#11332))
([29f7ce4](29f7ce4))
* Packable trait + using it for public storage
([#11136](#11136))
([e74ce15](e74ce15))
* Public logs
([#11091](#11091))
([f4725d2](f4725d2))
* Re-exposing `compute_initialization_hash`
([#11423](#11423))
([1ad2b70](1ad2b70))
* **reqresp:** Request l2 blocks
([#11337](#11337))
([73a6698](73a6698))
* **spartan:** Extra acounts with cl config
([#11301](#11301))
([13fed74](13fed74))
* UH recursion in the browser
([#11049](#11049))
([c3c04a4](c3c04a4))


### Bug Fixes

* **aztec.js:** Remove field from aztec address like
([#11350](#11350))
([26093f7](26093f7))
* **bootstrap:** Include crates in noir projects hashes
([#11344](#11344))
([1075113](1075113))
* **bootstrap:** Include crates in noir projects hashes take 2
([#11351](#11351))
([1f36a04](1f36a04))
* Clarify sepolia GA secrets
([#11424](#11424))
([cf3c911](cf3c911))
* **docs:** Downgrade docusaurus to v 3.6
([#11386](#11386))
([1e5d225](1e5d225))
* Don't publish a block if we failed to create the block proposal
([#11475](#11475))
([f589c90](f589c90))
* Flakey e2e_pruned_blocks test
([#11431](#11431))
([887b8ff](887b8ff))
* Hackily fix the public input columns of avm recursion constraint
([#11428](#11428))
([436c3c6](436c3c6))
* Hardcode value in constants
([#11442](#11442))
([dd0684a](dd0684a))
* Init fee juice contract in sandbox
([#11379](#11379))
([caab526](caab526))
* Lint
([#11389](#11389))
([87b0dee](87b0dee))
* Mnemonic needs quotes
([#11429](#11429))
([de8dad4](de8dad4))
* Move eslint in circuits.js to dev deps
([#11340](#11340))
([079a2c4](079a2c4))
* Network deployments
([#11463](#11463))
([0804913](0804913))
* Pad base fee in aztec.js
([#11370](#11370))
([d0e9a55](d0e9a55))
* Prevent PXE from making historical queries during note discovery
([#11406](#11406))
([23000d4](23000d4))
* Publish aztec packages
([#11434](#11434))
([d9bfd51](d9bfd51))
* Re-stage the git hook formatted files - doh
([#11430](#11430))
([02e6529](02e6529))
* **readme:** Remove stale link
([#11333](#11333))
([bfcd8a5](bfcd8a5))
* Spartan accounts
([#11321](#11321))
([fa9c9ce](fa9c9ce))
* **spartan:** Beacon node networking policy
([#11484](#11484))
([d5b9892](d5b9892))
* Stale selector comments
([#11311](#11311))
([629bd64](629bd64))
* Txe partial note support
([#11414](#11414))
([cd9cad9](cd9cad9))
* Update devbox
([#11339](#11339))
([aca84ff](aca84ff))
* Use simulation to estimate gas used
([#11211](#11211))
([63776f0](63776f0))
* Verify start state of a block
([#11290](#11290))
([5eb3e8f](5eb3e8f))
* Version undefined does not exist for tree NULLIFIER_TREE
([#11421](#11421))
([b1cb502](b1cb502))


### Miscellaneous

* Add a couple of comments in the AVM range check gadget
([#11402](#11402))
([f1fd2d1](f1fd2d1))
* Add OTEL_EXCLUDE_METRICS
([#11317](#11317))
([37d4fa8](37d4fa8))
* **avm:** Do not use commit_sparse
([#11447](#11447))
([9796e1e](9796e1e))
* **avm:** Remove some codegen bloat
([#11418](#11418))
([6b0106c](6b0106c))
* **bootstrap:** Refine noir contracts rebuild pattern
([#11367](#11367))
([90f5e8f](90f5e8f))
* Bump CRS and constants
([#11306](#11306))
([9e5ea3a](9e5ea3a))
* **ci:** Set correct image version in aztec image docker releases
([#11334](#11334))
([197db95](197db95))
* Dont install and run metrics stack on kind network smoke
([#11366](#11366))
([f66db63](f66db63))
* Exclude system metrics from k8s deployments
([#11401](#11401))
([31be5fb](31be5fb))
* Exp 2 with 128 validators
([#11483](#11483))
([206ca8d](206ca8d))
* Fix devnet deploy
([#11387](#11387))
([71d8ede](71d8ede))
* Fixed VK in MegaZK/ECCVM/Translator/Tube Recursive Verifier circuits
([#11377](#11377))
([5018c94](5018c94))
* Improving clarity of serialization in macros
([#11460](#11460))
([7790973](7790973))
* Increase initial fee juice mint
([#11369](#11369))
([bca7052](bca7052))
* Minor Gemini refactor to prep for opening k-shifts
([#11393](#11393))
([30a063a](30a063a))
* More granular error handling for toradixBE
([#11378](#11378))
([64f4052](64f4052)),
closes
[#11295](#11295)
* Nargo fmt pre-commit hook
([#11416](#11416))
([6f2e2e0](6f2e2e0))
* Nuking redundant oracle
([#11368](#11368))
([b32d9a1](b32d9a1))
* **p2p:** Disable flakey test
([#11380](#11380))
([94012b5](94012b5))
* **p2p:** Reorganise reqresp handlers
([#11327](#11327))
([f048acd](f048acd))
* Point to monorepo's nargo in vscode workspace settings
([#11349](#11349))
([bb96e7c](bb96e7c))
* Print warning in builder when failure happens.
([#11205](#11205))
([5a52e95](5a52e95))
* Public network with sepolia
([#11488](#11488))
([80f5a46](80f5a46))
* Rc-2 release on Sepolia
([#11479](#11479))
([bef7b0f](bef7b0f))
* Redo typo PR by Daulox92
([#11458](#11458))
([f3ba327](f3ba327))
* Redo typo PR by Dimitrolito
([#11413](#11413))
([d4b7075](d4b7075))
* Redo typo PR by nnsW3
([#11322](#11322))
([de64823](de64823))
* Redo typo PR by offensif
([#11411](#11411))
([a756578](a756578))
* Redo typo PR by savvar9991
([#11412](#11412))
([53ea3af](53ea3af))
* Redo typo PR by teenager-ETH
([#11320](#11320))
([77854e2](77854e2))
* Redo typo PR by teenager-ETH
([#11450](#11450))
([dd46152](dd46152))
* Reenable reqresp offline peers test
([#11384](#11384))
([931dfa6](931dfa6))
* Renaming emit unencrypted -&gt; emit public
([#11361](#11361))
([c047a12](c047a12))
* Replace relative paths to noir-protocol-circuits
([6f644cd](6f644cd))
* Replace relative paths to noir-protocol-circuits
([fe24778](fe24778))
* Replace relative paths to noir-protocol-circuits
([fcdb409](fcdb409))
* Replace relative paths to noir-protocol-circuits
([ea43aed](ea43aed))
* Replace relative paths to noir-protocol-circuits
([7653c69](7653c69))
* Replace relative paths to noir-protocol-circuits
([204476e](204476e))
* Serialize trait impls for U128 following intrinsic Noir serialization
([#11142](#11142))
([c5671d2](c5671d2))
* Slower exp2
([#11487](#11487))
([e995c0f](e995c0f))
* **sol:** Generate & compile verifier contract in bootstrap
([#11364](#11364))
([bf3b12a](bf3b12a))
* **spartan:** Apply release fixes post cl
([#11385](#11385))
([2bbf562](2bbf562))
* Stricter contributing rules
([#11462](#11462))
([2535425](2535425))
* Temporarily disable boxes
([#11472](#11472))
([f6c63fe](f6c63fe))
* Test starting multiple anvils allocates distinct ports
([#11314](#11314))
([e385ea9](e385ea9))
* Trace propagation from json rpc client to server
([#11325](#11325))
([85ccc15](85ccc15))
* Try fix e2e block building flake
([#11359](#11359))
([38fbd5c](38fbd5c))
* Try fix flakey public processor test
([#11348](#11348))
([8de55d4](8de55d4))
* Updated ethereum resource config
([#11485](#11485))
([8788561](8788561))
</details>

<details><summary>barretenberg: 0.72.0</summary>

##
[0.72.0](barretenberg-v0.71.0...barretenberg-v0.72.0)
(2025-01-24)


### ⚠ BREAKING CHANGES

* public logs
([#11091](#11091))

### Features

* **avm:** Address and class id derivation setup
([#11354](#11354))
([5f3cffc](5f3cffc))
* **avm:** Bytecode manager changes
([#11347](#11347))
([4a9c072](4a9c072))
* **avm:** Include initial tree roots in DB
([#11360](#11360))
([4d149be](4d149be))
* **avm:** Interactive debugger
([#11477](#11477))
([53e57d3](53e57d3))
* Eccvm sumcheck with commitments to round univariates
([#11206](#11206))
([fe34b05](fe34b05))
* Lazy wasm pt. 2
([#11410](#11410))
([01510f4](01510f4))
* Public logs
([#11091](#11091))
([f4725d2](f4725d2))
* UH recursion in the browser
([#11049](#11049))
([c3c04a4](c3c04a4))


### Bug Fixes

* Hackily fix the public input columns of avm recursion constraint
([#11428](#11428))
([436c3c6](436c3c6))
* Verify start state of a block
([#11290](#11290))
([5eb3e8f](5eb3e8f))


### Miscellaneous

* Add a couple of comments in the AVM range check gadget
([#11402](#11402))
([f1fd2d1](f1fd2d1))
* **avm:** Do not use commit_sparse
([#11447](#11447))
([9796e1e](9796e1e))
* **avm:** Remove some codegen bloat
([#11418](#11418))
([6b0106c](6b0106c))
* Bump CRS and constants
([#11306](#11306))
([9e5ea3a](9e5ea3a))
* Fixed VK in MegaZK/ECCVM/Translator/Tube Recursive Verifier circuits
([#11377](#11377))
([5018c94](5018c94))
* Minor Gemini refactor to prep for opening k-shifts
([#11393](#11393))
([30a063a](30a063a))
* More granular error handling for toradixBE
([#11378](#11378))
([64f4052](64f4052)),
closes
[#11295](#11295)
* Print warning in builder when failure happens.
([#11205](#11205))
([5a52e95](5a52e95))
* Redo typo PR by Daulox92
([#11458](#11458))
([f3ba327](f3ba327))
* Redo typo PR by teenager-ETH
([#11320](#11320))
([77854e2](77854e2))
* **sol:** Generate & compile verifier contract in bootstrap
([#11364](#11364))
([bf3b12a](bf3b12a))
</details>

---
This PR was generated with [Release
Please](https://github.com/googleapis/release-please). See
[documentation](https://github.com/googleapis/release-please#release-please).
  • Loading branch information
AztecBot authored Jan 24, 2025
1 parent e995c0f commit c0c4c1f
Show file tree
Hide file tree
Showing 8 changed files with 197 additions and 7 deletions.
8 changes: 4 additions & 4 deletions .release-please-manifest.json
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
{
".": "0.71.0",
".": "0.72.0",
"yarn-project/cli": "0.35.1",
"yarn-project/aztec": "0.71.0",
"barretenberg": "0.71.0",
"barretenberg/ts": "0.71.0"
"yarn-project/aztec": "0.72.0",
"barretenberg": "0.72.0",
"barretenberg/ts": "0.72.0"
}
116 changes: 116 additions & 0 deletions CHANGELOG.md

Large diffs are not rendered by default.

39 changes: 39 additions & 0 deletions barretenberg/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,44 @@
# Changelog

## [0.72.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.71.0...barretenberg-v0.72.0) (2025-01-24)


### ⚠ BREAKING CHANGES

* public logs ([#11091](https://github.com/AztecProtocol/aztec-packages/issues/11091))

### Features

* **avm:** Address and class id derivation setup ([#11354](https://github.com/AztecProtocol/aztec-packages/issues/11354)) ([5f3cffc](https://github.com/AztecProtocol/aztec-packages/commit/5f3cffc42bf2280367d44603ae6f509c46b6fede))
* **avm:** Bytecode manager changes ([#11347](https://github.com/AztecProtocol/aztec-packages/issues/11347)) ([4a9c072](https://github.com/AztecProtocol/aztec-packages/commit/4a9c0724e3dd6fa3ea8753fc17a090c33c307d01))
* **avm:** Include initial tree roots in DB ([#11360](https://github.com/AztecProtocol/aztec-packages/issues/11360)) ([4d149be](https://github.com/AztecProtocol/aztec-packages/commit/4d149be20e73321fece072a1b7e410225b5dc8c9))
* **avm:** Interactive debugger ([#11477](https://github.com/AztecProtocol/aztec-packages/issues/11477)) ([53e57d3](https://github.com/AztecProtocol/aztec-packages/commit/53e57d3d52dd477714bc984c4a13bc8e5664877e))
* Eccvm sumcheck with commitments to round univariates ([#11206](https://github.com/AztecProtocol/aztec-packages/issues/11206)) ([fe34b05](https://github.com/AztecProtocol/aztec-packages/commit/fe34b0580a308665c655a897c72f06bd05dcd4c4))
* Lazy wasm pt. 2 ([#11410](https://github.com/AztecProtocol/aztec-packages/issues/11410)) ([01510f4](https://github.com/AztecProtocol/aztec-packages/commit/01510f45aa5d385a08584df674d9caf9522e6be2))
* Public logs ([#11091](https://github.com/AztecProtocol/aztec-packages/issues/11091)) ([f4725d2](https://github.com/AztecProtocol/aztec-packages/commit/f4725d2237c6e9c6b7b17248f8c33343cb9ea7f1))
* UH recursion in the browser ([#11049](https://github.com/AztecProtocol/aztec-packages/issues/11049)) ([c3c04a4](https://github.com/AztecProtocol/aztec-packages/commit/c3c04a4cb92f0447431160d425bda66a997c0d66))


### Bug Fixes

* Hackily fix the public input columns of avm recursion constraint ([#11428](https://github.com/AztecProtocol/aztec-packages/issues/11428)) ([436c3c6](https://github.com/AztecProtocol/aztec-packages/commit/436c3c63b76e36d172619436b3237133f295aca7))
* Verify start state of a block ([#11290](https://github.com/AztecProtocol/aztec-packages/issues/11290)) ([5eb3e8f](https://github.com/AztecProtocol/aztec-packages/commit/5eb3e8f498093ae52b8a29939051cd8c66aed3c1))


### Miscellaneous

* Add a couple of comments in the AVM range check gadget ([#11402](https://github.com/AztecProtocol/aztec-packages/issues/11402)) ([f1fd2d1](https://github.com/AztecProtocol/aztec-packages/commit/f1fd2d104d01a4582d8a48a6ab003d8791010967))
* **avm:** Do not use commit_sparse ([#11447](https://github.com/AztecProtocol/aztec-packages/issues/11447)) ([9796e1e](https://github.com/AztecProtocol/aztec-packages/commit/9796e1ea2720e6ee01be20b4c9226257c9efb0a9))
* **avm:** Remove some codegen bloat ([#11418](https://github.com/AztecProtocol/aztec-packages/issues/11418)) ([6b0106c](https://github.com/AztecProtocol/aztec-packages/commit/6b0106c1eedf098779e7903ac37e96e6b3a9d478))
* Bump CRS and constants ([#11306](https://github.com/AztecProtocol/aztec-packages/issues/11306)) ([9e5ea3a](https://github.com/AztecProtocol/aztec-packages/commit/9e5ea3a6a45c1266504ec3c259b9c11aa4fd9f7a))
* Fixed VK in MegaZK/ECCVM/Translator/Tube Recursive Verifier circuits ([#11377](https://github.com/AztecProtocol/aztec-packages/issues/11377)) ([5018c94](https://github.com/AztecProtocol/aztec-packages/commit/5018c94db30ea80c93d194453d1c837a51fbe3a0))
* Minor Gemini refactor to prep for opening k-shifts ([#11393](https://github.com/AztecProtocol/aztec-packages/issues/11393)) ([30a063a](https://github.com/AztecProtocol/aztec-packages/commit/30a063a65f95403773d13da0d9a896da45d9608d))
* More granular error handling for toradixBE ([#11378](https://github.com/AztecProtocol/aztec-packages/issues/11378)) ([64f4052](https://github.com/AztecProtocol/aztec-packages/commit/64f4052d498496724ec56b207ca0f89c3fe87ac8)), closes [#11295](https://github.com/AztecProtocol/aztec-packages/issues/11295)
* Print warning in builder when failure happens. ([#11205](https://github.com/AztecProtocol/aztec-packages/issues/11205)) ([5a52e95](https://github.com/AztecProtocol/aztec-packages/commit/5a52e950428b511ea3024efb32c6d1c9b810fd89))
* Redo typo PR by Daulox92 ([#11458](https://github.com/AztecProtocol/aztec-packages/issues/11458)) ([f3ba327](https://github.com/AztecProtocol/aztec-packages/commit/f3ba32709a9776d6b737e976fb652ae466ca916e))
* Redo typo PR by teenager-ETH ([#11320](https://github.com/AztecProtocol/aztec-packages/issues/11320)) ([77854e2](https://github.com/AztecProtocol/aztec-packages/commit/77854e2c92ccf11dea3770845928ca5077a606d8))
* **sol:** Generate & compile verifier contract in bootstrap ([#11364](https://github.com/AztecProtocol/aztec-packages/issues/11364)) ([bf3b12a](https://github.com/AztecProtocol/aztec-packages/commit/bf3b12a374dddb8f7993e0c1537cfa6042f86f38))

## [0.71.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.70.0...barretenberg-v0.71.0) (2025-01-17)


Expand Down
2 changes: 1 addition & 1 deletion barretenberg/cpp/CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 3.24 FATAL_ERROR)
project(
Barretenberg
DESCRIPTION "BN254 elliptic curve library, and PLONK SNARK prover"
VERSION 0.71.0 # x-release-please-version
VERSION 0.72.0 # x-release-please-version
LANGUAGES CXX C
)
# Insert version into `bb` config file
Expand Down
15 changes: 15 additions & 0 deletions barretenberg/ts/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,20 @@
# Changelog

## [0.72.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.71.0...barretenberg.js-v0.72.0) (2025-01-24)


### Features

* Gaztec ([#11229](https://github.com/AztecProtocol/aztec-packages/issues/11229)) ([79f810d](https://github.com/AztecProtocol/aztec-packages/commit/79f810dc682d41154eb723e5bdf4c54c0681becb))
* Lazy wasm pt.1 ([#11371](https://github.com/AztecProtocol/aztec-packages/issues/11371)) ([864bc6f](https://github.com/AztecProtocol/aztec-packages/commit/864bc6f34431dee17e76c476716821996d2ff9e5))
* Lazy wasm pt3 ([#11435](https://github.com/AztecProtocol/aztec-packages/issues/11435)) ([7068d05](https://github.com/AztecProtocol/aztec-packages/commit/7068d055d91a6e81e6fbb670e17c77ee209a1a80))
* UH recursion in the browser ([#11049](https://github.com/AztecProtocol/aztec-packages/issues/11049)) ([c3c04a4](https://github.com/AztecProtocol/aztec-packages/commit/c3c04a4cb92f0447431160d425bda66a997c0d66))


### Bug Fixes

* Lint ([#11389](https://github.com/AztecProtocol/aztec-packages/issues/11389)) ([87b0dee](https://github.com/AztecProtocol/aztec-packages/commit/87b0deea9bb6291120cc5166359fc32efd1fbfce))

## [0.71.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.70.0...barretenberg.js-v0.71.0) (2025-01-17)


Expand Down
2 changes: 1 addition & 1 deletion barretenberg/ts/package.json
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
{
"name": "@aztec/bb.js",
"packageManager": "[email protected]",
"version": "0.71.0",
"version": "0.72.0",
"homepage": "https://github.com/AztecProtocol/aztec-packages/tree/master/barretenberg/ts",
"license": "MIT",
"type": "module",
Expand Down
20 changes: 20 additions & 0 deletions yarn-project/aztec/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,25 @@
# Changelog

## [0.72.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.71.0...aztec-package-v0.72.0) (2025-01-24)


### Features

* Gaztec ([#11229](https://github.com/AztecProtocol/aztec-packages/issues/11229)) ([79f810d](https://github.com/AztecProtocol/aztec-packages/commit/79f810dc682d41154eb723e5bdf4c54c0681becb))
* Lazy wasm pt. 2 ([#11410](https://github.com/AztecProtocol/aztec-packages/issues/11410)) ([01510f4](https://github.com/AztecProtocol/aztec-packages/commit/01510f45aa5d385a08584df674d9caf9522e6be2))
* Lazy wasm pt3 ([#11435](https://github.com/AztecProtocol/aztec-packages/issues/11435)) ([7068d05](https://github.com/AztecProtocol/aztec-packages/commit/7068d055d91a6e81e6fbb670e17c77ee209a1a80))


### Bug Fixes

* Init fee juice contract in sandbox ([#11379](https://github.com/AztecProtocol/aztec-packages/issues/11379)) ([caab526](https://github.com/AztecProtocol/aztec-packages/commit/caab52671cfcf20b395a9e44a8768dc81d986cb5))
* Use simulation to estimate gas used ([#11211](https://github.com/AztecProtocol/aztec-packages/issues/11211)) ([63776f0](https://github.com/AztecProtocol/aztec-packages/commit/63776f0d217fad800bf8a6c6144d6bb52844e629))


### Miscellaneous

* Trace propagation from json rpc client to server ([#11325](https://github.com/AztecProtocol/aztec-packages/issues/11325)) ([85ccc15](https://github.com/AztecProtocol/aztec-packages/commit/85ccc1512cd9b1c461660ad8127dae848fde1878))

## [0.71.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.70.0...aztec-package-v0.71.0) (2025-01-17)


Expand Down
2 changes: 1 addition & 1 deletion yarn-project/aztec/package.json
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
{
"name": "@aztec/aztec",
"version": "0.71.0",
"version": "0.72.0",
"type": "module",
"exports": {
".": "./dest/index.js"
Expand Down

0 comments on commit c0c4c1f

Please sign in to comment.