Add Aliases to Schedule Timer Methods for Consistent Naming #54260
Unanswered
mhomeister
asked this question in
Ideas
Replies: 0 comments
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
-
Proposal: Add Aliases to Schedule Timer Methods for Consistent Naming
Hi everyone,
I’d like to propose adding aliases to some existing schedule timer methods to improve consistency and usability, especially for non-native English speakers.
Current Situation:
Currently, we have methods like:
everyMinute
everyTenMinutes
everyFourHours
hourly
daily
dailyAt
hourlyAt
While these work well, the naming conventions for
hourly
,daily
,dailyAt
, andhourlyAt
differ from theeveryX
pattern used in other methods (e.g.,everyMinute
,everyTenMinutes
). For developers whose native language includes terms like sekündlich or minütlich (e.g., in German), consistent naming could make the API easier to use and understand. These terms directly translate to "secondly" and "minutely," which are either uncommon or non-existent in English. However, in German and similar languages, they are valid and intuitive words.Proposal:
Rather than renaming the existing methods, I propose adding the following aliases:
hourly
→everyHour
daily
→everyDay
hourlyAt
→everyHourAt
dailyAt
→everyDayAt
weekly
,monthly
,yearly
This change would not break existing functionality, as the original method names (
hourly
,daily
,hourlyAt
,dailyAt
) would remain intact.Benefits:
everyX
format improves predictability and reduces potential confusion.hourly
,daily
,hourlyAt
, anddailyAt
will continue to work without changes.Implementation:
everyHour
as an alias forhourly
.everyDay
as an alias fordaily
.everyHourAt
as an alias forhourlyAt
.everyDayAt
as an alias fordailyAt
.Looking forward to your feedback!
Beta Was this translation helpful? Give feedback.
All reactions