-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathfarenheitToCelsiusTable
72 lines (60 loc) · 1.74 KB
/
farenheitToCelsiusTable
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
/*
Given three values - Start Fahrenheit Value (S), End Fahrenheit value (E) and Step Size (W),
you need to convert all Fahrenheit values from Start to End at the gap of W, into their corresponding Celsius values and print the table.
Input Format :
3 integers - S, E and W respectively
Output Format :
Fahrenheit to Celsius conversion table. One line for every Fahrenheit and corresponding
Celsius value in integer form. The Fahrenheit value and its corresponding Celsius value should be separate by single space.
Constraints :
0 <= S <= 90
S <= E <= 900
0 <= W <= 80
Sample Input 1:
0
100
20
Sample Output 1:
0 -17
20 -6
40 4
60 15
80 26
100 37
Sample Input 2:
20
119
13
Sample Output 2:
20 -6
33 0
46 7
59 15
72 22
85 29
98 36
111 43
Explanation For Input 2:
Start calculating the Celsius values for each Fahrenheit Value which starts from 20.
So starting from 20, we need to compute its corresponding Celsius value which computes to -6.
We print this information as <Fahrenheit Value> <a single space> <Celsius Value> on each line.
Now add 13 to Fahrenheit Value at each step until you reach 119 in this case.
You may or may not exactly land on the end value depending on the steps you are taking.*/
import java.util.*;
public class Solution {
public static void main(String[] args) {
/* Your class should be named Solution.
* Read input as specified in the question.
* Print output as specified in the question.
*/
Scanner sc = new Scanner(System.in);
int start = sc.nextInt();
int end = sc.nextInt();
int width = sc.nextInt();
while(start<=end){
int celsius = (start-32)*5/9;
System.out.println(start + " " + celsius);
start+=width;
}
}
}