Skip to content

Commit 2ebd3ad

Browse files
authored
Upgrade to latest master (walnascar) (#20)
* upgrade to latest master (walnascar) * move root user's home directory to /root * add yocto-space-optimize, as poky does * TCLIBAPPEND was removed * bump versions * cargo config.toml instead of cargo config
1 parent b8f08bc commit 2ebd3ad

27 files changed

+185
-119
lines changed

kas/base.yml

+18-8
Original file line numberDiff line numberDiff line change
@@ -10,14 +10,15 @@ local_conf_header:
1010
CONF_VERSION = "2"
1111
EXTRA_IMAGE_FEATURES += "allow-empty-password"
1212
CLANGSDK = "1"
13+
ROOT_HOME = "/root"
1314
1415
repos:
1516
meta-nao:
1617
layers:
1718
meta:
1819
poky:
1920
url: "https://git.yoctoproject.org/git/poky"
20-
commit: ae6cebca5bac9521230c69fed23b375d0de7f5f6
21+
commit: 65de362ce818438ad60893f400a3c6d3915619d8
2122
layers:
2223
meta:
2324
meta-poky:
@@ -26,28 +27,37 @@ repos:
2627
0003-specify-custom-dynamic-linker:
2728
repo: "meta-nao"
2829
path: "patches/0003-bindgen-clang-sysroot.patch"
29-
0004-compress-sdk-with-zstd:
30+
0006-cargo-config-is-deprecated:
3031
repo: "meta-nao"
31-
path: "patches/0004-compress-sdk-with-zstd.patch"
32+
path: "patches/0006-cargo-config-is-deprecated.patch"
3233
meta-congatec-x86:
3334
url: "https://git.congatec.com/x86/meta-congatec-x86.git"
3435
commit: 1867244888ed0a5ad85f5b4ab789e1d0201deb02
3536
patches:
36-
0001-congatec-scarthgap-support:
37+
0001-congatec-walnascar-support:
3738
repo: "meta-nao"
38-
path: "patches/0001-congatec-scarthgap-support.patch"
39+
path: "patches/0001-congatec-walnascar-support.patch"
3940
0002-congatec-new-override-syntax:
4041
repo: "meta-nao"
4142
path: "patches/0002-congatec-new-override-syntax.patch"
43+
0004-congatec-no-s-workspace.patch:
44+
repo: "meta-nao"
45+
path: "patches/0004-congatec-no-s-workspace.patch"
46+
0005-congatec-upstream-status.patch:
47+
repo: "meta-nao"
48+
path: "patches/0005-congatec-upstream-status.patch"
4249
meta-clang:
4350
url: "https://github.com/kraj/meta-clang.git"
44-
commit: e7dceb1c92caf7f21ef1d7b49c85328c30cffd90
51+
commit: 03f578578be34734aed9b03d33fa031add5c9bf5
4552
meta-intel:
4653
url: "https://git.yoctoproject.org/git/meta-intel"
47-
commit: c8cd0317ec19332bce86697f3413a82b9828b329
54+
commit: b0fe7e45ab711e2ffbe996f3737dd63b2e273676
55+
meta-openvino:
56+
url: "https://github.com/intel/meta-openvino"
57+
commit: bd05014ef7f4a156f61f64ad40c9ffb282d32558
4858
meta-openembedded:
4959
url: "https://git.openembedded.org/meta-openembedded"
50-
commit: 4a7bb77f7ebe0ac8be5bab5103d8bd993e17e18d
60+
commit: d29b3f2b102678926fb35d205889d0aee2304114
5161
layers:
5262
meta-oe:
5363
meta-multimedia:

meta-hulks/conf/distro/HULKs-OS.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -4,5 +4,5 @@ SUMMARY = "HULKs flavoured Nao"
44

55
DISTRO = "HULKs-OS"
66
DISTRO_NAME = "HULKs-OS"
7-
DISTRO_VERSION = "7.5.9"
7+
DISTRO_VERSION = "7.6.0"
88
SDKIMAGE_FEATURES:remove = "dbg-pkgs src-pkgs"

meta-hulks/conf/layer.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -5,7 +5,7 @@ BBPATH .= ":${LAYERDIR}"
55
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
66
${LAYERDIR}/recipes-*/*/*.bbappend"
77

8-
LAYERSERIES_COMPAT_hulks = "scarthgap"
8+
LAYERSERIES_COMPAT_hulks = "walnascar"
99

1010
BBFILE_COLLECTIONS += "hulks"
1111
BBFILE_PATTERN_hulks = "^${LAYERDIR}/"

meta-hulks/recipes-core/images/nao-image.bbappend

-2
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,5 @@
11
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
22

3-
SDK_ZSTD_COMPRESSION_LEVEL = "-9"
4-
53
CORE_IMAGE_EXTRA_INSTALL += "\
64
aliveness \
75
breeze \

meta-hulks/recipes-hulks/aliveness/aliveness.bb

+2-2
Original file line numberDiff line numberDiff line change
@@ -17,8 +17,8 @@ inherit systemd
1717

1818
do_install:append () {
1919
install -d "${D}${systemd_unitdir}/system"
20-
install -m 0644 "${WORKDIR}/aliveness.service" "${D}${systemd_unitdir}/system/"
21-
install -m 0644 "${WORKDIR}/enp4s0-wait-online.service" "${D}${systemd_unitdir}/system/"
20+
install -m 0644 "${UNPACKDIR}/aliveness.service" "${D}${systemd_unitdir}/system/"
21+
install -m 0644 "${UNPACKDIR}/enp4s0-wait-online.service" "${D}${systemd_unitdir}/system/"
2222
}
2323

2424
require aliveness-crates.inc

meta-hulks/recipes-hulks/breeze/breeze.bb

+1-1
Original file line numberDiff line numberDiff line change
@@ -30,7 +30,7 @@ inherit systemd
3030
export BINDGEN_EXTRA_CLANG_ARGS="-I ${STAGING_INCDIR}"
3131
do_install:append() {
3232
install -d ${D}${systemd_unitdir}/system/
33-
install -m 0644 ${WORKDIR}/breeze.service ${D}${systemd_unitdir}/system/
33+
install -m 0644 ${UNPACKDIR}/breeze.service ${D}${systemd_unitdir}/system/
3434
}
3535

3636
require breeze-crates.inc

meta-hulks/recipes-hulks/hula/hula.bb

+2-2
Original file line numberDiff line numberDiff line change
@@ -31,9 +31,9 @@ inherit systemd
3131

3232
do_install:append() {
3333
install -d ${D}${systemd_unitdir}/system/
34-
install -m 0644 ${WORKDIR}/hula.service ${D}${systemd_unitdir}/system/
34+
install -m 0644 ${UNPACKDIR}/hula.service ${D}${systemd_unitdir}/system/
3535
install -d ${D}${datadir}/dbus-1/system.d/
36-
install -m 0644 ${WORKDIR}/org.hulks.hula.conf ${D}${datadir}/dbus-1/system.d/
36+
install -m 0644 ${UNPACKDIR}/org.hulks.hula.conf ${D}${datadir}/dbus-1/system.d/
3737
}
3838

3939
FILES:${PN} += "${datadir}/dbus-1/system.d/org.hulks.hula.conf"

meta-hulks/recipes-hulks/hulk/hulk.bb

+7-4
Original file line numberDiff line numberDiff line change
@@ -10,18 +10,21 @@ SRC_URI = "\
1010
file://hulk \
1111
"
1212

13+
S = "${WORKDIR}/sources"
14+
UNPACKDIR = "${S}"
15+
1316
SYSTEMD_SERVICE:${PN} = "hulk.service hulk-gdbserver.service"
1417

1518
inherit systemd
1619

1720
do_install() {
1821
install -d ${D}${bindir}
19-
install -m 755 ${WORKDIR}/launchHULK ${D}${bindir}
20-
install -m 755 ${WORKDIR}/hulk ${D}${bindir}
22+
install -m 755 ${S}/launchHULK ${D}${bindir}
23+
install -m 755 ${S}/hulk ${D}${bindir}
2124

2225
install -d ${D}${systemd_unitdir}/system/
23-
install -m 0644 ${WORKDIR}/hulk.service ${D}${systemd_unitdir}/system/
24-
install -m 0644 ${WORKDIR}/hulk-gdbserver.service ${D}${systemd_unitdir}/system/
26+
install -m 0644 ${S}/hulk.service ${D}${systemd_unitdir}/system/
27+
install -m 0644 ${S}/hulk-gdbserver.service ${D}${systemd_unitdir}/system/
2528
}
2629

2730
FILES:${PN} = " \

meta-hulks/recipes-hulks/network-config/network-config.bb

+8-5
Original file line numberDiff line numberDiff line change
@@ -14,16 +14,19 @@ SRC_URI = "\
1414
file://network-fallback-notification.service \
1515
"
1616

17+
S = "${WORKDIR}/sources"
18+
UNPACKDIR = "${S}"
19+
1720
do_install() {
1821
install -d ${D}${sbindir}/
19-
install -m 0755 ${WORKDIR}/configure_network ${D}${sbindir}/
22+
install -m 0755 ${S}/configure_network ${D}${sbindir}/
2023
install -d ${D}${systemd_unitdir}/system/
21-
install -m 0644 ${WORKDIR}/network-config.service ${D}${systemd_unitdir}/system/
22-
install -m 0644 ${WORKDIR}/network-fallback-notification.service ${D}${systemd_unitdir}/system/
24+
install -m 0644 ${S}/network-config.service ${D}${systemd_unitdir}/system/
25+
install -m 0644 ${S}/network-fallback-notification.service ${D}${systemd_unitdir}/system/
2326
install -d ${D}/var/lib/iwd/
24-
install -m 0600 ${WORKDIR}/SPL_HULKs.psk ${D}/var/lib/iwd/
27+
install -m 0600 ${S}/SPL_HULKs.psk ${D}/var/lib/iwd/
2528
install -d ${D}/${datadir}/network-config/
26-
install -m 0600 ${WORKDIR}/fallback_notification.wav ${D}/${datadir}/network-config/
29+
install -m 0600 ${S}/fallback_notification.wav ${D}/${datadir}/network-config/
2730
}
2831

2932
FILES:${PN} = " \

meta/conf/distro/nao-core-minimal.conf

+1-2
Original file line numberDiff line numberDiff line change
@@ -21,11 +21,10 @@ PREFERRED_PROVIDER_virtual/kernel = "linux-intel-rt"
2121
PREFERRED_PROVIDER_cgos-mod = "linux-intel-rt"
2222
KERNEL_MODULE_AUTOLOAD:append = " cgosdrv"
2323

24-
TCLIBCAPPEND = ""
25-
2624
PACKAGE_CLASSES ?= "package_ipk"
2725

2826
require conf/distro/include/no-static-libs.inc
27+
require conf/distro/include/yocto-space-optimize.inc
2928

3029
BB_SIGNATURE_HANDLER ?= "OEEquivHash"
3130
BB_HASHSERVE ??= "auto"

meta/conf/layer.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -5,7 +5,7 @@ BBPATH .= ":${LAYERDIR}"
55
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
66
${LAYERDIR}/recipes-*/*/*.bbappend"
77

8-
LAYERSERIES_COMPAT_nao = "scarthgap"
8+
LAYERSERIES_COMPAT_nao = "walnascar"
99

1010
BBFILE_COLLECTIONS += "nao"
1111
BBFILE_PATTERN_nao = "^${LAYERDIR}/"

meta/recipes-conf/nao-wifi-conf/nao-wifi-conf.bb

+11-7
Original file line numberDiff line numberDiff line change
@@ -11,19 +11,23 @@ SRC_URI = "\
1111
file://SPL_E.psk \
1212
file://SPL_F.psk \
1313
"
14+
15+
S = "${WORKDIR}/sources"
16+
UNPACKDIR = "${S}"
17+
1418
RDEPENDS:${PN} = "iwd"
1519

1620
do_install() {
1721
install -d ${D}${sysconfdir}/iwd/
18-
install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/iwd/
22+
install -m 0644 ${S}/main.conf ${D}${sysconfdir}/iwd/
1923

2024
install -d ${D}/var/lib/iwd/
21-
install -m 0600 ${WORKDIR}/SPL_A.psk ${D}/var/lib/iwd/
22-
install -m 0600 ${WORKDIR}/SPL_B.psk ${D}/var/lib/iwd/
23-
install -m 0600 ${WORKDIR}/SPL_C.psk ${D}/var/lib/iwd/
24-
install -m 0600 ${WORKDIR}/SPL_D.psk ${D}/var/lib/iwd/
25-
install -m 0600 ${WORKDIR}/SPL_E.psk ${D}/var/lib/iwd/
26-
install -m 0600 ${WORKDIR}/SPL_F.psk ${D}/var/lib/iwd/
25+
install -m 0600 ${S}/SPL_A.psk ${D}/var/lib/iwd/
26+
install -m 0600 ${S}/SPL_B.psk ${D}/var/lib/iwd/
27+
install -m 0600 ${S}/SPL_C.psk ${D}/var/lib/iwd/
28+
install -m 0600 ${S}/SPL_D.psk ${D}/var/lib/iwd/
29+
install -m 0600 ${S}/SPL_E.psk ${D}/var/lib/iwd/
30+
install -m 0600 ${S}/SPL_F.psk ${D}/var/lib/iwd/
2731
}
2832

2933
FILES:${PN} = "\

meta/recipes-conf/user-home/nao-home.bb

+5-2
Original file line numberDiff line numberDiff line change
@@ -7,18 +7,21 @@ SRC_URI = "\
77
file://nao.rules \
88
"
99

10+
S = "${WORKDIR}/sources"
11+
UNPACKDIR = "${S}"
12+
1013
RDEPENDS:${PN} += "polkit"
1114

1215
inherit useradd
1316

1417
do_install:append() {
1518
# Enable robocupper mode
1619
install -o nao -g nao -d ${D}/home/nao/
17-
install -o nao -g nao -m 0644 ${WORKDIR}/robocup.conf ${D}/home/nao/
20+
install -o nao -g nao -m 0644 ${S}/robocup.conf ${D}/home/nao/
1821

1922
# Install nao rules for polkit
2023
install -d ${D}${datadir}/polkit-1/rules.d/
21-
install ${WORKDIR}/nao.rules ${D}${datadir}/polkit-1/rules.d
24+
install ${S}/nao.rules ${D}${datadir}/polkit-1/rules.d
2225
}
2326

2427
USERADD_PACKAGES = "${PN}"

meta/recipes-core/base-files/base-files_%.bbappend

+1-1
Original file line numberDiff line numberDiff line change
@@ -7,5 +7,5 @@ do_install:append() {
77
install -d ${D}/media/internal
88

99
install -d ${D}${sysconfdir}/profile.d/
10-
install -m 0644 ${WORKDIR}/sbin_path.sh ${D}${sysconfdir}/profile.d/
10+
install -m 0644 ${UNPACKDIR}/sbin_path.sh ${D}${sysconfdir}/profile.d/
1111
}

meta/recipes-kernel/linux/linux-intel-rt/0001-NAO-adjustments-in-part-by-SoftBank-and-Congatec.patch

+1
Original file line numberDiff line numberDiff line change
@@ -2,6 +2,7 @@ From 165a4bcc4c62e984fe0ae7213298140a55ef5b9b Mon Sep 17 00:00:00 2001
22
From: Maximilian Schmidt <[email protected]>
33
Date: Tue, 12 Mar 2024 10:54:44 +0000
44
Subject: [PATCH] NAO adjustments (in part by SoftBank and Congatec)
5+
Upstream-Status: Pending
56

67
---
78
arch/x86/mm/ioremap.c | 3 +-

meta/recipes-kernel/linux/linux-intel-rt/0002-CGOS-32-bit.patch

+1
Original file line numberDiff line numberDiff line change
@@ -2,6 +2,7 @@ From 2a7f46283db624091165a0383882c44f578d645b Mon Sep 17 00:00:00 2001
22
From: Kas User <[email protected]>
33
Date: Tue, 15 Nov 2022 19:33:29 +0000
44
Subject: [PATCH] CGOS 32-bit
5+
Upstream-Status: Pending
56

67
---
78
drivers/cgosdrv/DrvLx.c | 63 ++++++++++++++++++++++++++++++++++-------

meta/recipes-kernel/linux/linux-intel-rt_%.bbappend

+1-1
Original file line numberDiff line numberDiff line change
@@ -13,7 +13,7 @@ RPROVIDES:${KERNEL_PACKAGE_NAME} += "cgos-mod"
1313
do_install:append() {
1414
ln -s bzImage-${KERNEL_VERSION_NAME} ${D}/boot/vmlinuz.efi
1515
ln -s vmlinuz.efi ${D}/boot/vmlinuz
16-
install -m 0644 ${WORKDIR}/cmdline ${D}/boot/cmdline
16+
install -m 0644 ${UNPACKDIR}/cmdline ${D}/boot/cmdline
1717
}
1818

1919
FILES:${KERNEL_PACKAGE_NAME} += "\

meta/recipes-support/aldebaran/aldebaran-binaries.bb

+11-8
Original file line numberDiff line numberDiff line change
@@ -4,6 +4,9 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-3.0-only;md5=c79ff39f19dfec
44

55
SRC_URI = "file://aldebaran_binaries.tar.gz;sha256sum=02848f1b604c3afc7d52b4f01bc83434250709c720f86619eeb39d0bf6701c27"
66

7+
S = "${WORKDIR}/sources"
8+
UNPACKDIR = "${S}"
9+
710
RDEPENDS:${PN} += "bash"
811

912
INHIBIT_PACKAGE_STRIP = "1"
@@ -15,24 +18,24 @@ ALDEBARAN_LIB_DIR = "/opt/aldebaran/lib"
1518

1619
do_install() {
1720
install -d ${D}/opt/aldebaran/share/firmware/
18-
install -m 0644 ${WORKDIR}/aldebaran_files/opt/aldebaran/share/firmware/CX3RDK_OV5640_USB2.img ${D}/opt/aldebaran/share/firmware/
19-
install -m 0644 ${WORKDIR}/aldebaran_files/opt/aldebaran/share/firmware/CX3RDK_OV5640_USB3.img ${D}/opt/aldebaran/share/firmware/
21+
install -m 0644 ${S}/aldebaran_files/opt/aldebaran/share/firmware/CX3RDK_OV5640_USB2.img ${D}/opt/aldebaran/share/firmware/
22+
install -m 0644 ${S}/aldebaran_files/opt/aldebaran/share/firmware/CX3RDK_OV5640_USB3.img ${D}/opt/aldebaran/share/firmware/
2023

2124
install -d ${D}/${nonarch_base_libdir}/firmware
22-
install ${WORKDIR}/aldebaran_files/lib/firmware/sbre-usb-i2c.dfuse ${D}/${nonarch_base_libdir}/firmware
25+
install ${S}/aldebaran_files/lib/firmware/sbre-usb-i2c.dfuse ${D}/${nonarch_base_libdir}/firmware
2326

2427
install -d ${D}/opt/aldebaran/etc/
25-
install -D ${WORKDIR}/aldebaran_files/opt/aldebaran/etc/alfand.conf ${D}/opt/aldebaran/etc/
28+
install -D ${S}/aldebaran_files/opt/aldebaran/etc/alfand.conf ${D}/opt/aldebaran/etc/
2629
install -d ${D}/opt/aldebaran/etc/hal
27-
install -D ${WORKDIR}/aldebaran_files/opt/aldebaran/etc/hal/hal.xml ${D}/opt/aldebaran/etc/hal/
30+
install -D ${S}/aldebaran_files/opt/aldebaran/etc/hal/hal.xml ${D}/opt/aldebaran/etc/hal/
2831
install -d ${D}/opt/aldebaran/share/lola
29-
install -D ${WORKDIR}/aldebaran_files/opt/aldebaran/share/lola/nao_v6.xml ${D}/opt/aldebaran/share/lola/
32+
install -D ${S}/aldebaran_files/opt/aldebaran/share/lola/nao_v6.xml ${D}/opt/aldebaran/share/lola/
3033

3134
install -d ${D}/${ALDEBARAN_BIN_DIR}
32-
install -D ${WORKDIR}/aldebaran_files/opt/aldebaran/bin/* ${D}/${ALDEBARAN_BIN_DIR}
35+
install -D ${S}/aldebaran_files/opt/aldebaran/bin/* ${D}/${ALDEBARAN_BIN_DIR}
3336

3437
install -d ${D}/${ALDEBARAN_LIB_DIR}
35-
install -D ${WORKDIR}/aldebaran_files/opt/aldebaran/lib/* ${D}/${ALDEBARAN_LIB_DIR}
38+
install -D ${S}/aldebaran_files/opt/aldebaran/lib/* ${D}/${ALDEBARAN_LIB_DIR}
3639
}
3740

3841
do_package_qa[noexec] = "1"

meta/recipes-support/aldebaran/aldebaran.bb

+13-10
Original file line numberDiff line numberDiff line change
@@ -17,30 +17,33 @@ SRC_URI = "\
1717
file://lola.service \
1818
"
1919

20+
S = "${WORKDIR}/sources"
21+
UNPACKDIR = "${S}"
22+
2023
ALDEBARAN_DIR = "/opt/aldebaran"
2124

2225
do_install() {
2326
install -d ${D}${sysconfdir}/udev/rules.d/
24-
install -m 0644 ${WORKDIR}/42-usb-cx3.rules ${D}${sysconfdir}/udev/rules.d/
25-
install -m 0644 ${WORKDIR}/90-cgos.rules ${D}${sysconfdir}/udev/rules.d/
26-
install -m 0644 ${WORKDIR}/90-hal.rules ${D}${sysconfdir}/udev/rules.d/
27+
install -m 0644 ${S}/42-usb-cx3.rules ${D}${sysconfdir}/udev/rules.d/
28+
install -m 0644 ${S}/90-cgos.rules ${D}${sysconfdir}/udev/rules.d/
29+
install -m 0644 ${S}/90-hal.rules ${D}${sysconfdir}/udev/rules.d/
2730

2831
install -d ${D}/${nonarch_base_libdir}/systemd/system-shutdown/
29-
install -m 755 ${WORKDIR}/harakiri ${D}/${nonarch_base_libdir}/systemd/system-shutdown
32+
install -m 755 ${S}/harakiri ${D}/${nonarch_base_libdir}/systemd/system-shutdown
3033

3134
install -d ${D}${systemd_unitdir}/system
32-
install -m 0644 ${WORKDIR}/alfand.service ${D}${systemd_unitdir}/system
33-
install -m 0644 ${WORKDIR}/hal.service ${D}${systemd_unitdir}/system
34-
install -m 0644 ${WORKDIR}/lola.service ${D}${systemd_unitdir}/system
35+
install -m 0644 ${S}/alfand.service ${D}${systemd_unitdir}/system
36+
install -m 0644 ${S}/hal.service ${D}${systemd_unitdir}/system
37+
install -m 0644 ${S}/lola.service ${D}${systemd_unitdir}/system
3538

3639
install -d ${D}/${sysconfdir}/tmpfiles.d/
37-
install -m 0644 ${WORKDIR}/00-hal-log.conf ${D}/${sysconfdir}/tmpfiles.d/
40+
install -m 0644 ${S}/00-hal-log.conf ${D}/${sysconfdir}/tmpfiles.d/
3841

3942
install -d ${D}/${sysconfdir}/security/limits.d/
40-
install -m 0644 ${WORKDIR}/rt-group.conf ${D}/${sysconfdir}/security/limits.d/
43+
install -m 0644 ${S}/rt-group.conf ${D}/${sysconfdir}/security/limits.d/
4144

4245
install -d ${D}${sysconfdir}/profile.d/
43-
install -m 0644 ${WORKDIR}/aldebaran_path.sh ${D}${sysconfdir}/profile.d/
46+
install -m 0644 ${S}/aldebaran_path.sh ${D}${sysconfdir}/profile.d/
4447
}
4548

4649
FILES:${PN} = "\

meta/recipes-support/aldebaran/flash-cx3/0001-Use-libusb-context-instead-of-NULL.patch

+1
Original file line numberDiff line numberDiff line change
@@ -2,6 +2,7 @@ From b9486eaaa3e4c66bfab7d383612babc9c63a6735 Mon Sep 17 00:00:00 2001
22
From: Hendrik <[email protected]>
33
Date: Tue, 3 May 2022 16:55:10 +0200
44
Subject: [PATCH] Use libusb context instead of NULL
5+
Upstream-Status: Pending
56

67
---
78
src/FX3Device.cpp | 2 +-

meta/recipes-support/aldebaran/flash-cx3/0002-Include-cstdint.patch

+1
Original file line numberDiff line numberDiff line change
@@ -2,6 +2,7 @@ From 93996a51f564b65d556896f4b3180122d03934c9 Mon Sep 17 00:00:00 2001
22
From: Maximilian Schmidt <[email protected]>
33
Date: Tue, 12 Mar 2024 12:23:13 +0000
44
Subject: [PATCH] Include cstdint
5+
Upstream-Status: Pending
56

67
---
78
src/FX3Device.hpp | 1 +

patches/0001-congatec-scarthgap-support.patch patches/0001-congatec-walnascar-support.patch

+2-2
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
From 78ee96785053ecb3198963d0d781930a35935874 Mon Sep 17 00:00:00 2001
22
From: Maximilian Schmidt <[email protected]>
33
Date: Wed, 9 Nov 2022 17:38:52 +0100
4-
Subject: [PATCH] congatec scarthgap support
4+
Subject: [PATCH] congatec walnascar support
55

66
---
77
conf/layer.conf | 2 +-
@@ -16,7 +16,7 @@ index 60cc30c..a7825ff 100644
1616

1717
LAYERVERSION_congatec = "7"
1818
-LAYERSERIES_COMPAT_congatec = "dunfell"
19-
+LAYERSERIES_COMPAT_congatec = "scarthgap"
19+
+LAYERSERIES_COMPAT_congatec = "walnascar"
2020
--
2121
2.30.2
2222

0 commit comments

Comments
 (0)