You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
It can't find glaze.hpp despite adding the git submodule 0d2e3e2
There are also several warning abotu both ztd and glaze, like
meson.build:338: WARNING: include_directories sandbox violation!
The project is trying to access the directory 'subprojects/glaze/include' which belongs to a different
subproject. This is a problem as it hardcodes the relative paths of these two projects.
This makes it impossible to compile the project in any other directory layout and also
prevents the subproject from changing its own directory layout.
Instead of poking directly at the internals the subproject should be executed and
it should set a variable that the caller can then use. Something like:
# In subproject
some_dep = declare_dependency(include_directories: include_directories('include'))
# In subproject wrap file
[provide]
some = some_dep
# In parent project
some_dep = dependency('some')
executable(..., dependencies: [some_dep])
This warning will become a hard error in a future Meson release.
The text was updated successfully, but these errors were encountered:
It can't find
glaze.hpp
despite adding the git submodule 0d2e3e2There are also several warning abotu both
ztd
andglaze
, likeThe text was updated successfully, but these errors were encountered: