-
Notifications
You must be signed in to change notification settings - Fork 4
/
Copy pathCrossword Problem.cpp
242 lines (195 loc) · 4.35 KB
/
Crossword Problem.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
/*
PROBLEM:
CodingNinjas has provided a crossword of 10*10 grid. The grid contains '+' or '-' as its cell values. Now, you are also provided with a word list that needs to placed accurately in the grid. Cells marked with '-' are to be filled with word list.
For example, The following is an example for the input crossword grid and the word list.
+-++++++++
+-++-+++++
+-------++
+-++-+++++
+-++-+++++
+-++-+++++
++++-+++++
++++-+++++
++++++++++
----------
CALIFORNIA;NIGERIA;CANADA;TELAVIV
Output for the given input should be:
+C++++++++
+A++T+++++
+NIGERIA++
+A++L+++++
+D++A+++++
+A++V+++++
++++I+++++
++++V+++++
++++++++++
CALIFORNIA
Note: We have provided such test cases that there is only one solution for the given input.
Input format:
The first 10 lines of input contain crossword. Each of 10 lines has a character array of size 10. Input characters are either '+' or '-'.
The next line of input contains the word list, in which each word is separated by ';'.
Output format:
Print the crossword grid, after placing the words of word list in '-' cells.
Sample Test Cases:
Sample Input 1:
+-++++++++
+-++-+++++
+-------++
+-++-+++++
+-++-+++++
+-++-+++++
++++-+++++
++++-+++++
++++++++++
----------
CALIFORNIA;NIGERIA;CANADA;TELAVIV
Sample Output 1:
+C++++++++
+A++T+++++
+NIGERIA++
+A++L+++++
+D++A+++++
+A++V+++++
++++I+++++
++++V+++++
++++++++++
CALIFORNIA
CODE:
*/
#include<iostream>
using namespace std;
char crossWord[10][10];
bool isValidHorizontal(int row, int col, string word){
if(10 - col < word.length())
return false;
for (int i = 0, j = col; i < word.length(); ++i,j++)
{
if (crossWord[row][j] != '-' && crossWord[row][j] != word[i]){
return false;
}
}
return true;
}
bool isValidVertical(int row, int col, string word){
if(10 - row < word.length())
return false;
for (int i = row, j = 0; j < word.length(); ++i,j++)
{
if (crossWord[i][col] != '-' && crossWord[i][col] != word[j]){
return false;
}
}
return true;
}
void setHorizontal(int row, int col, string word, bool state[]){
for (int i = 0, j = col; i < word.size(); ++i, j++)
{
if (crossWord[row][j] != '+'){
if(crossWord[row][j] == word[i])
state[i] = false;
else
state[i] = true;
crossWord[row][j] = word[i];
}
}
}
void setVertical(int row, int col, string word, bool state[]){
for (int i = 0, j = row; i < word.size(); ++i, j++)
{
if (crossWord[j][col] != '+'){
if(crossWord[j][col] == word[i])
state[i] = false;
else
state[i] = true;
crossWord[j][col] = word[i];
}
}
}
void resetHorizontal(int row, int col, bool state[], int size){
for (int i = 0, j = col; i < size; ++i,j++)
{
if(state[i] == true)
crossWord[row][j] = '-';
}
return;
}
void resetVertical(int row, int col, bool state[], int size){
for (int i = 0, j = row; i < size; ++i,j++)
{
if(state[i] == true)
crossWord[j][col] = '-';
}
return;
}
void set_value(bool helper[],int len ){
for(int i=0;i<len;i++){
helper[i] = false;
}
}
bool crossWordHelper(string input[], int size, int index){
if(index == size){
for(int i =0; i<10; i++){
for(int j=0; j<10; j++){
cout << crossWord[i][j] ;
}
cout << endl;
}
return true;
}
for(int i =0; i<10; i++){
for(int j=0; j<10; j++){
if(crossWord[i][j] == '-' || crossWord[i][j] == input[index][0]){
int length = input[index].size();
bool state[length];
set_value(state,length);
if(isValidHorizontal(i, j, input[index])){
setHorizontal(i, j, input[index], state);
if(crossWordHelper(input, size, index+1)){
return true;
}
resetHorizontal(i, j, state, length);
}
if(isValidVertical(i, j, input[index])){
setVertical(i, j, input[index], state);
if(crossWordHelper(input, size, index+1)){
return true;
}
resetVertical(i, j, state, length);
}
}
}
}
return false;
}
void solveCrossWord(string input[], int size){
bool res = crossWordHelper(input, size, 0);
return;
}
int main(){
string ss;
for(int i = 0; i<10; i++){
cin >>ss;
for(int j = 0; j < ss.size(); j++){
crossWord[i][j] = ss[j];
}
}
char s[200];
cin >> s;
string input[10];
char ch;
string word ="";
int a =0;
for (int i = 0; s[i] != '\0'; ++i)
{
if(s[i] == ';'){
input[a++] = word;
word ="";
}
else {
word += s[i];
}
}
input[a++] = word;
solveCrossWord(input, a);
return 0;
}